Contents

About This Online Guide ................................................................. 5
  How to use this online guide .......................................................... 5
  Structure of this guide ................................................................. 5
  General information on this guide .................................................. 6

About Diva Server for Windows 2000/XP ........................................ 7
  Features ...................................................................................... 7
  Supported hardware ..................................................................... 10
  Requirements for software installation ........................................... 11
  Information on installing downloaded software ............................... 12

Software Installation ........................................................................ 13
  Installing fully detected Diva Server adapters ................................. 14
  Installing Diva Server adapters detected as ‘New Hardware’ .......... 18

Software Configuration ................................................................. 27
  Configuration with installed hardware ............................................ 27
  Manual configuration .................................................................... 28

Configuration Manager ................................................................. 30
  Configuration pane ....................................................................... 30
  Properties pane ............................................................................ 33
  Activating a configuration ............................................................. 34
  Saving a configuration ................................................................ 34
  Line properties ............................................................................ 35
  Adapter properties ....................................................................... 49
  RAS properties .......................................................................... 51
  Modem properties ....................................................................... 55
  Modem pool properties ............................................................... 58
  CAPI properties ......................................................................... 59
  TAPI properties ......................................................................... 60
  Binding properties ....................................................................... 63

Configuration Scenarios ............................................................... 68
  Fax server .................................................................................. 68
  RAS server ................................................................................ 69

www.eicon.com/divaserver
CTI server ............................................................................................................. 70

Eicon Port Driver .................................................................................................. 71
  Addressing the Eicon Port driver directly .......................................................... 71
  AT-command set of the Eicon Port driver .......................................................... 71

Dial-Up Networking and RAS Administration .............................................. 81
  RAS client setup ............................................................................................... 81
  RAS server setup ............................................................................................. 88
  RAS status .......................................................................................................... 91

Changing Your Installation ........................................................................... 94
  Adding Diva Server adapters ........................................................................... 94
  Uninstalling ....................................................................................................... 94

Shorthold .............................................................................................................. 95
  Breaking and re-establishing connections ....................................................... 95
  Exclusive allocation of charges ...................................................................... 96
  Shorthold and Multilink PPP ........................................................................... 98
  Callback numbers ............................................................................................ 98

Security Dynamics Authentication ............................................................... 99
  Security Dynamics authentication via modem emulation ............................... 99

Management Tools ......................................................................................... 102
  Diva Server Monitor ....................................................................................... 102

Maintenance Tools .......................................................................................... 106
  Line Check ........................................................................................................ 106
  Diva Server Diagnostics .................................................................................. 108

Features ............................................................................................................. 113
  On-board switching and conferencing ......................................................... 116
  Supplementary services .................................................................................... 117
CHAPTER 1

About This Online Guide

How to use this online guide

- To view a section, click the corresponding bookmark located on the left.
- To view a topic that contains further information, click the corresponding blue underlined phrase.
- You may wish to print out the pages required for installing the drivers.

Structure of this guide

This guide provides a detailed description of how to install and configure Diva Server for Windows 2000/XP, and how to troubleshoot your ISDN connection.

This guide is structured as follows:

<table>
<thead>
<tr>
<th>Section</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Diva Server for Windows 2000/XP</td>
<td>Diva Server for Windows 2000/XP features, supported hardware, and requirements for software installation</td>
</tr>
<tr>
<td>Software Installation</td>
<td>Installation of the basic drivers</td>
</tr>
<tr>
<td>Software Configuration</td>
<td>Starting a configuration with installed hardware or performing a manual configuration</td>
</tr>
<tr>
<td>Configuration Manager</td>
<td>General layout of the configuration manager and properties of all available components in the configuration manager</td>
</tr>
<tr>
<td>Configuration Scenarios</td>
<td>Examples of how to set up different server types with the configuration manager</td>
</tr>
<tr>
<td>Eicon Port Driver</td>
<td>Information on how to use the Eicon Port driver for non-TAPI applications, AT commands</td>
</tr>
<tr>
<td>Dial-Up Networking and RAS Administration</td>
<td>RAS client and RAS server setup</td>
</tr>
<tr>
<td>Shorthold</td>
<td>Information on the shorthold feature</td>
</tr>
<tr>
<td>Security Dynamics Authentication</td>
<td>Information on the Security Dynamics authentication feature</td>
</tr>
<tr>
<td>Changing Your Installation</td>
<td>Adding new Diva Server adapters, uninstalling</td>
</tr>
<tr>
<td>Management Tools</td>
<td>Tools available for monitoring active connections and getting statistic information on all connections</td>
</tr>
</tbody>
</table>
General information on this guide

- This guide describes the installation of the Diva Server for Windows 2000/XP software.
- Paths of the CD-ROM drive are indicated with the drive letter ‘D’. If necessary, change the drive letter according to your system configuration.
CHAPTER 2

About Diva Server for Windows 2000/XP


Features

The list below provides an overview of the features supported by Diva Server for Windows 2000/XP. For information on further supported features, refer to the ‘Features’ section at the back of this reference guide.

General Features

- Support for ISDN basic-rate interface (BRI), ISDN primary-rate interface (PRI), and for the channelized T1 interface
- Support for fractional lines
- Automatic Diva Server adapter detection
- Support for ISDN lines with a transfer rate of 64 kbps or 56 kbps (e.g. USA)
- Support for channelized T1 lines with a transfer rate of 56 kbps (see Channelized T1 (robbed bit signaling) on page 10)
- Up to 120 B-channels
- Modem connections up to 56 kbps (V.90)
- COM port (modem emulation)
- Support for CAPI-based applications through CAPI 2032.DLL and CAPI 20.DLL (32-bit and 16-bit versions) for Windows 2000 or Windows XP
- Support for TAPI-based applications through the Diva Server Telephony Service Provider (TSP)
- Can be used internationally with support for all known ISDN protocols (switch types)
• Support for Q-Sig protocol (see Q-Sig features on page 10)
• Additional security through Security Dynamics support
• Interfaces: RAS WMP, modem emulation, CAPI, Diva Server TSP

RAS features

Note: RAS is the Routing and Remote Access Service of Windows 2000 or Windows XP.

• Connection to ISDN routers, enabling access to a remote LAN or the Internet
• Network access for PPP-compatible clients
• Connection to a Windows 2000 or Windows XP server from digital, analog, and mobile networks with only one telephone number
• Automatic detection of ISDN service, synchronous/asynchronous framing and B-channel protocol
• Synchronous/asynchronous conversion
• Support for LAN protocols: TCP/IP, IPX/SPX, NetBIOS, NetBEUI, LAN Manager API
• Support for B-channel protocols: HDLC, X.75, V.120, V.110, PIAFS 1.0 and 2.1, modem V.94+ and V.90, fax connections, V.42/LAPM (error correction), and V.42bis compression
• Encryption, data compression, number checking, shorthold mode, callback function

Modem emulation

• COM port for 16-bit Windows applications
• TAPI-compliant pre-initialized modems
  • Eicon Diva Analog Modem
  • Eicon Diva Fax Modem
    Fax Class 1
    Fax Class 2
  • Eicon Diva V.120 Modem (64K)
  • Eicon Diva V.120 Modem (56K)
  • Eicon Diva V.110 Modem
  • Eicon Diva X.75 Modem (64K)
  • Eicon Diva X.75 Modem (56K)
  • Eicon Diva PPP-Modem (64K)
  • Eicon Diva PPP-Modem (56K)
• Eicon Diva X.25 Modem
• Eicon Diva Generic Server Modem
  Network access for PPP-compatible clients
  Automatic detection of ISDN service, synchronous/asynchronous framing and B-channel protocol
  Synchronous/asynchronous conversion
  Encryption, data compression, number checking, shorthold mode, callback function

CAPI features

Supplementary services:
• Number identification services: MSN, DDI, SUB, CLIP, CLIR, COLP, COLR, KEY
• Call offering services: TP, CFU, CFB, CFNR
• Call completion services: CW, HOLD, ECT
• Charging services: AoC
• Three-party conference
• Others: User-to-user signaling

Fax and voice features
• Fax compression (MH, MR 2D coding, MMR T.6 coding) and error-correction mode (ECM)
• Fax connections up to 33,6 kbps
• Class 1 and class 2 fax interface
• Fax polling
• Extended fax
• Fax tone detection
• Reversal of fax direction
• Dynamic switching of B-channel protocols
• DTMF transmission, detection
• Cross-board switching via interline connect (DSP-based monitor, bridge, and mixer for voice connections: supports multiline conference calls)
• Page formats: ISO A4, ISO B4, ISO A3
• Standard, fine, super-fine, and ultra-fine resolution
• Echo cancellation
• Real time protocol (RTP)
• Dynamic anti-jitter buffering
• Comfort noise generation (CNG)
• Voice activity detection (VAD)

**Diva Server TSP features**

• Supplementary services based on CAPI: CLIP, CLIR, COLP, COLR, HOLD, CFU, CFB, CFNR, ECT, AoC
• Media mode (unknown, interactive voice, automated voice)
• Wave audio format (8 bit 8 kHz a-law, 8 bit 8 kHz μ-law, 8 bit 8 kHz PCM)
• DTMF tone generation and detection (based on CAPI)

**Q-Sig features**

• Basic call
• Redirected number
• Connected name
• Advice of charge (AoC)
• Message waiting

**Channelized T1 (robbed bit signaling)**

• Trunk modes (loop, ground, and wink start)
• Tone dialing (DTMF and MF)
• Pulse dialing
• Ringer and busy tone detection
• 56 kbps transfer rate

**Supported hardware**

Diva Server for Windows 2000/XP supports the following Eicon Diva Server adapters:

**ISDN BRI adapters**

• Diva Server 2FX
• Diva Server BRI-2M ISA
• Diva Server BRI-2M PCI
• Diva Server BRI-2M 2.0 PCI
• Diva Server Voice BRI-2M 2.0 PCI
• Diva Server 4BRI-8M PCI
• Diva Server 4BRI-8M 2.0 PCI
• Diva Server Voice 4BRI-8M PCI
• Diva Server Voice 4BRI-8M 2.0 PCI

ISDN PRI adapters
• Diva Server PRI PCI: Diva Server PRI PCI, Diva Server PRI-9M PCI, Diva Server PRI-23M PCI, Diva Server PRI-30M PCI
• Diva Server PRI 2.0 PCI: Diva Server PRI-0M PCI, Diva Server PRI-4M PCI, Diva Server PRI-8M PCI, Diva Server PRI-30M 2.0 PCI
• Diva Server Voice PRI PCI: Diva Server Voice PRI-4M PCI, Diva Server Voice PRI-8M PCI, Diva Server Voice PRI-30M PCI

T1 adapters
• Diva Server T1/PRI PCI: Diva Server T1/PRI PCI, Diva Server T1/PRI-4M PCI, Diva Server T1/PRI-8M PCI, Diva Server T1/PRI-24M PCI
• Diva Server Voice T1/PRI PCI: Diva Server Voice T1/PRI-4M PCI, Diva Server Voice T1/PRI-8M PCI, Diva Server Voice T1/PRI-24M PCI

Diva Server for Windows 2000/XP supports the installation of multiple (max. 4) Eicon Diva Server adapters in one computer.

Requirements for software installation
For the installation of Diva Server for Windows 2000/XP, the following requirements have to be met:

• PC/AT-compatible computer (Pentium 133 MHz or higher processor with 128 MB RAM)
• Windows 2000 or Windows XP operating system
• At least 15 MB free space on the drive on which the Windows 2000 or Windows XP operating system is installed
• An installed Eicon Diva Server adapter
To install your Diva Server adapter in your computer, refer to the printed guide that came with your adapter.

**Information on installing downloaded software**

If you downloaded the Diva Server for Windows 2000/XP software from the Eicon Web site, please note the following:

- Extract the files to your hard disk drive. Do not change the directory structure of the extracted files.
- This manual assumes that the installation files have been copied into the directory ‘C:\ISDN’. If necessary, change the drive letter or path according to your system configuration.
CHAPTER 3

Software Installation

You should not attempt to install the software for your Eicon Diva Server adapter at the same time as the Windows 2000 or Windows XP operating system.

The installation procedure depends on the type of Diva Server adapter and the operating system that you have:

Windows 2000

- If you are installing one of the following adapters, see Installing fully detected Diva Server adapters on page 14:
  - Diva Server BRI-2M
  - Diva Server PRI version
  - Diva Server 4BRI-8M

- If you are installing one of the following adapters, see the section Installing Diva Server adapters detected as ‘New Hardware’ on page 18:
  - Diva Server 2FX
  - Diva Server T1/PRI version
  - Diva Server BRI-2M 2.0
  - Diva Server 4BRI-8M 2.0
  - Diva Server PRI version
  - Diva Server Voice BRI-2M 2.0
  - Diva Server Voice 4BRI-8M 2.0
  - Diva Server Voice T1/PRI version
  - Diva Server Voice PRI version

Windows XP

- If you are installing one of the following adapters, see Installing fully detected Diva Server adapters on page 14:
  - Diva Server BRI-2M
  - Diva Server PRI version
  - Diva Server 4BRI-8M
  - Diva Server PRI 2.0 version

- If you are installing one of the following adapters, see the section Installing Diva Server adapters detected as ‘New Hardware’ on page 18:
  - Diva Server 2FX
  - Diva Server Voice 4BRI-8M
  - Diva Server BRI-2M 2.0
  - Diva Server Voice BRI-2M 2.0
  - Diva Server 4BRI-8M 2.0
  - Diva Server Voice 4BRI-8M 2.0
Installing fully detected Diva Server adapters

1. After you have installed your Diva Server adapter as described in the printed installation guide that came with your adapter, start your computer.
   
   **Note:** You must log on with administrator rights to install Diva Server for Windows 2000/XP.

2. Windows 2000 or Windows XP detects the Diva Server adapter.

3. *Windows XP only:* The ‘Found New Hardware Wizard’ is displayed. Click ‘Next’ to continue.

4. In the ‘ISDN Switch Type or D-channel Protocol’ dialog box, select the D-channel protocol (switch type) as specified by your ISDN service provider, e.g. European ISDN (DSS1).

Click ‘Next’.
5. **Europe and all other countries except North America:**
The ‘ISDN Multisubscriber Numbers’ dialog box is displayed:

You may enter the MSNs or the extension range that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

**North America only:**
If you are using a North American switch type and a BRI adapter, the ‘ISDN Phone Number and SPID Information’ dialog box is displayed.
You may enter the phone number and SPIID that you want to assign to RAS here. It is, however, recommendable to assign the phone numbers later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no phone numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

If you are using a North American switch type and a Diva Server PRI adapter, the ‘ISDN Phone Number Information’ dialog box is displayed.

![ISDN Phone Number Information](image)

You may enter the phone numbers that you want to assign to RAS here. It is, however, recommendable to assign the phone numbers later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no phone numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

6. **Windows XP only:** In the ‘Found New Hardware Wizard’, click ‘Finish’.

The standard Windows 2000 or Windows XP drivers for your Diva Server adapter are installed. To be able to use all features of Diva Server for Windows 2000/XP, you must update the drivers with the software that is provided on your Diva Server CD-ROM or that you downloaded from the Eicon Networks web site.
To update the drivers:

1. From the Windows task bar, click ‘Start > Run’.

2. Type the path to the update file:
   - Insert your Diva Server CD-ROM into the CD-ROM drive and enter the following path:
     \D:\DRIVER\WIN2K\ENGLISH\UPDATE.EXE
     (where D: is your CD-ROM drive letter).
   - Or enter the path to the update file on the hard disk, e.g.
     C:\ISDN\UPDATE.EXE
     (where C: is the hard disk drive letter).

3. In the welcome dialog box, click ‘Next’ to start updating the drivers for all installed Diva Server adapters.

   The appropriate files are copied to your system.

**Note:** If a message appears warning you that the software has not been tested with Windows, continue the installation. This message only indicates that the Diva Server for Windows 2000/XP software does not have Microsoft’s signature. This does not prevent a correct installation of the software.
4. When the copy process is complete, click ‘Finish’ to complete the update.

Note: Depending on your system configuration, you are prompted to restart your computer. Make sure that the ‘Restart your computer’ option is checked to restart the computer after the update is complete.

You can now open the configuration manager to add components to your Diva Server for Windows 2000/XP software and configure them.

See Configuration with installed hardware on page 27.

Installing Diva Server adapters detected as ‘New Hardware’

The installation procedure of Diva Server adapters detected as ‘New Hardware’ depends on your operating system:

- If you are installing the Diva Server adapter under Windows 2000, see To install the Diva Server adapter under Windows 2000: below.
- If you are installing the Diva Server adapter under Windows XP, see To install the Diva Server adapter under Windows XP: on page 23.

To install the Diva Server adapter under Windows 2000:

1. After you have installed your Diva Server adapter as described in the printed guide that came with your adapter, start your computer.

   Note: You must log on with administrator rights to install Diva Server for Windows 2000/XP.

2. Windows 2000 detects the new hardware and starts the ‘Found New Hardware Wizard’.

3. In the welcome dialog box, click ‘Next’.
4. In the ‘Install Hardware Device Drivers’ dialog box, select ‘Search for a suitable driver for my device (recommended)’.

5. In the ‘Locate Driver Files’ dialog box, select ‘Specify a location’. Disable all other options.

6. In the displayed dialog box enter the path to the installation files:
   
   - Insert your Diva Server CD-ROM into the CD-ROM drive and enter the following path:
     
     \D:\DRIVER\WIN2K\ENGLISH\  
     
     (where \D: is your CD-ROM drive letter).
• Or enter the path to the installation file on the hard disk, e.g.

    C: \ ISDN\n
    (where C: is the hard disk drive letter).

    Click ‘OK’.

7. In the ‘Driver Files Search Results’ dialog box, verify that Windows 2000 has found the appropriate drivers.

    Click ‘Next’ to continue the installation.

    **Note:** If a message appears indicating that the software has not been tested with Windows, continue the installation. This message only indicates that the Diva Server for Windows 2000/XP software does not have Microsoft's signature. This does not prevent a correct installation of the software.

8. In the ‘ISDN Switch Type or D-channel Protocol’ dialog box, select the switch type as specified by your ISDN service provider, e.g. European ISDN (DSS1).

    ![ISDN Switch Type or D-channel Protocol dialog box]

    Click ‘Next’.
9. **Europe and all other countries except North America:**
The ‘ISDN Multisubscriber Numbers’ dialog box is displayed.

You may enter the MSNs or the extension range that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

**North America only:**
If you are using a North American switch type and a BRI adapter, the ‘ISDN Phone Number and SPID Information’ dialog box is displayed:
You may enter the phone number and SPID (Service Profil ID) that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

If you are using a North American switch type and a Diva Server PRI adapter, the ‘ISDN Phone Number Information’ dialog box is displayed:

You may enter the phone numbers that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

10. In the displayed dialog box, click ‘Finish’ to complete the installation.

11. Restart your computer.

You can now open the configuration manager to add components to your Diva Server for Windows 2000/XP software and configure them.

See [Configuration with installed hardware](#) on page 27.
To install the Diva Server adapter under Windows XP:

1. After you have installed your Diva Server adapter as described in the printed guide that came with your adapter, start your computer and log on with administrator rights to install Diva Server for Windows 2000/XP.

2. Windows XP detects the new hardware and starts the ‘Found New Hardware Wizard’.

Select ‘Install from a list or specific location (Advanced)’. Click ‘Next’.
3. In the displayed dialog box, select ‘Search for the best driver in these locations’.

Enable ‘Include this location in the search’. Disable all other search options.

Type the path to the installation files:

- Insert your Diva Server CD-ROM into the CD-ROM drive and enter the following path:
  
  D:\DRIVER\WIN2K\ENGLISH
  
  (where D: is your CD-ROM drive letter).

- Or enter the path to the installation file on the hard disk, e.g.

  C:\ISDN\n
  (where C: is the hard disk drive letter).

Click ‘Next’ to install the drivers.

**Note:** If a message appears indicating that the software has not passed Windows logo testing, click ‘Continue Anyway’. This message only indicates that the Diva Server for Windows/XP does not have Microsoft's digital signature. This does not prevent a correct installation of the software.
4. In the ‘ISDN Switch Type or D-channel Protocol’ dialog box, select the switch type as specified by your ISDN service provider, e.g. European ISDN (DSS1).

Click ‘Next’.

5. **Europe and all other countries except North America:**
The ‘ISDN Multisubscriber Numbers’ dialog box is displayed.

You may enter the MSNs or the extension range that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

**Note:** If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.
North America only:
The ‘ISDN Phone Number and SPID Information’ dialog box is displayed.

You may enter the phone number and SPID (Service Profile ID) that you want to assign to RAS here. It is, however, recommendable to assign the MSNs or extension range later on in the Diva Server Configuration Manager because it provides a complete overview of the number configuration.

Click ‘Next’.

Note: If you configure and assign no ISDN numbers at all, neither in the ISDN wizard nor later on in the configuration manager, RAS accepts all incoming calls.

6. In the displayed dialog box, click ‘Finish’ to complete the installation.

7. Restart your computer.

You can now open the configuration manager to add components to your Diva Server for Windows 2000/XP software and configure them.

See Configuration with installed hardware on page 27.
CHAPTER 4

Software Configuration

Configuration with installed hardware

After you installed your Diva Server adapter and the adapter drivers as described in Software Installation on page 13, you can start the configuration manager:

1. Click ‘Start > Programs > Diva Server for Windows 2000/XP > Diva Server Configuration Manager’.

2. The configuration manager displays the basic configuration that was set up by the adapter drivers:
   - The detected Diva Server adapter is installed.
   - The adapter is assumed to be connected to a corresponding ISDN BRI or PRI line. Line properties are either default or the parameters that you set in the Windows ISDN wizard.
   - RAS is installed and connected to the Diva Server adapter.
   - CAPI is installed and connected to the Diva Server adapter.

If you have not assigned a number to RAS in Microsoft’s ISDN wizard, both, RAS and CAPI, are configured to accept all incoming calls. This can cause conflicts between the two services. To avoid these conflicts, you should assign different MSN(s), ISDN numbers, or extension(s) to the services in the binding properties for each service.

When you are using a North-American protocol with a BRI line, you must always assign ISDN numbers because otherwise incoming calls cannot be accepted (see Bindings between Diva Server adapters and services on page 64).
See below an example of a basic installation for a Diva Server BRI-2M (PCI):

3. You can now add components to your Diva Server for Windows 2000/XP software and configure them as described in the section Configuration Manager on page 30.

**Manual configuration**

You can configure the software manually, without having an installed Diva Server adapter. The manual configuration enables a system administrator to create a complete configuration and save it as a configuration file. This configuration file can be made available to the users who then only need to install the adapter drivers and to activate the configuration created by the system administrator. As such, users do not need to configure the software.

Please note that you can only activate a configuration file for your system if the Diva Server adapter(s) that are available in the configuration manager correspond to the Diva Server adapter(s) which are physically installed in your computer.

To activate an existing configuration file for your system, open the configuration file and click ‘File > Activate’; or click the activate button ▶️ in the toolbar.
To start the configuration manager:

1. Click ‘Start > Run’.
2. Type the path to the configuration manager:
   - Insert your Diva Server CD-ROM into your CD-ROM drive and enter the following path:
     D:\DRIVER\WIN2K\ENGLISH\DISRVCFG.EXE
     (where D: is your CD-ROM drive letter).
   - Or enter the path to the configuration file on the hard disk, e.g.
     C:\ISDN\DISRVCFG.EXE
     (where C: is the hard disk drive letter).
   Click ‘OK’.
3. The configuration manager is displayed with no components at all:

   ![Configuration Manager Window]

4. You can now do a complete manual configuration as described in the section Configuration Manager on page 30.

   **Note:** If configuration files have been created before, you can start the configuration manager and select a default configuration from the list or load a configuration file. The selected configuration file is displayed and you can modify it according to your requirements.
CHAPTER 5

Configuration Manager

The configuration manager allows you to set up your complete configuration.

The configuration manager window is split into two panes, the configuration pane which shows the complete configuration and the properties pane which shows the properties of a specific component.

Online help is available for all components and their properties.

- To view the online help for a selected component or property, press the F1 key.
- To view the online help for all components and configurable parameters, click ‘Help’ from the menu bar and select ‘Contents’.
- To view the online help for a certain component, toolbar button or menu option, click the ‘What's this’ button and the element for which you want to view the online help.

Configuration pane

The configuration pane shows the complete configuration.

Note: If your configuration is very complex and contains many components, you can change the size of the configuration pane to have a better view of your configuration. Click ‘View > Split’, drag the split bar to the desired position and click the mouse button.

The configuration pane has three logical layers (from bottom to top):

- Lines - line layer for ISDN BRI, ISDN PRI, or T1 lines
- Adapters - adapter layer for the Diva Server adapter(s)
- Services - services layer for RAS, CAPI, etc.

To create a configuration, add components to each layer and then connect them by bindings. Each component is represented by an icon. The following components are available for the various layers:

Lines - line layer

- Basic Rate Line (BRI): Basic rate ISDN line that provides two B-channels at 64 kbps each and one D-channel at 16 kbps. This line can be connected to any Diva Server BRI-2M, 2FX, or Voice BRI-2M or to one port of any Diva Server 4BRI or Voice 4BRI adapter.
- Primary Rate Line (PRI/T1/E1): Primary rate ISDN line that provides up to 30 B-channels at 64 kbps each and one D-channel at 64 kbps. This line can be connected to any Diva Server PRI, T1/PRI, Diva Server Voice PRI, or Voice T1/PRI adapter.
• T1 Line: Channelized T1 line that provides up to 24 channels at 56 kbps each. This line can be connected to any Diva Server PRI, T1/PRI, Diva Server Voice PRI, or Voice T1/PRI adapter.

Adapters - layer for the Diva Server adapters

• Diva Server 2FX: It can be connected to one ISDN BRI line using two B-channels and one D-channel.
• Diva Server BRI-2M PCI: It can be connected to one ISDN BRI line using two B-channels and one D-channel.
• Diva Server BRI-2M ISA: It can be connected to one ISDN BRI line using two B-channels and one D-channel.
• Diva Server 4BRI-8M PCI: It can be connected to up to four ISDN BRI lines using up to eight B-channels and four D-channels.
• Diva Server PRI PCI or Diva Server T1/PRI PCI: It can be connected to an ISDN PRI line using up to 30 B-channels and one D-channel or to a channelized T1 line using up to 24 channels.
• Diva Server Voice BRI-2M PCI: It can be connected to one ISDN BRI line using two B-channels and one D-channel.
• Diva Server Voice 4BRI-8M PCI: It can be connected to up to four ISDN BRI lines using up to eight B-channels and four D-channels.
• Diva Server Voice PRI PCI or Diva Server Voice T1/PRI PCI: It can be connected to an ISDN PRI line using up to 30 B-channels and one D-channel or to a channelized T1 line using up to 24 channels.

The adapter icons indicate the status of the adapter. See the examples below:

Services - service layer

• RAS (WAN Miniport): Remote Access Service of Windows 2000 or Windows XP. The WAN-Miniport adapter is included in the RAS.
• Modem: Virtual modems for fax, V.110, V.120, etc.
• Modem Pool: A pool of virtual modems for fax, V.110, V.120, etc.
• CAPI: Common Application Programming Interface used by many ISDN applications
• TAPI: Diva Server Telephony Service Provider

To add a component to the configuration:

1. From the menu bar, click ‘Insert’ and select the component you want to add to your configuration; or right-click in the configuration pane near the layer to which you want to add a component and select the desired component in the pop-up menu.

2. The component icon is displayed in the corresponding layer of the configuration pane.
   
   **Note:** If you add a Diva Server adapter to the configuration and there are no free lines available for this adapter, the appropriate lines are automatically added and connected to the Diva Server adapter.

3. If you want to change the horizontal position of the icon, click the icon and drag it to the desired position.
   
   **Note:** If you move an icon between two other icons and there is not enough space between the two other icons, then the icon that you try to move goes back to its original position.

To connect components:

The Diva Server adapters can be connected to lines. Service components can be connected to the Diva Server adapters. There is no direct connection between lines and service components.

1. Select the component you want to connect.

2. Right-click the component, keep the mouse button pressed and drag the arrow to the component to which you want to connect; or click the connect button in the toolbar and then click the component to which you want to connect.

3. The connection is indicated by a binding.

You can also create several bindings in one step. To do so, select the component, you want to connect. Then click the connect button, press the CTRL key and click the components to which you want to connect.

To remove a component or binding:

1. Right-click the component or binding that you want to remove.

2. In the pop-up menu, select ‘Remove’.

You can also remove a component or a binding by selecting it and clicking the remove button in the toolbar.
Properties pane

The properties of components and bindings are shown in the properties pane. See below an example for the properties pane of the RAS component with advanced parameters being displayed:

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total RAS Ports</td>
<td>2</td>
</tr>
<tr>
<td>Callback Prefix</td>
<td></td>
</tr>
<tr>
<td>Use Defaults for Callback</td>
<td>No</td>
</tr>
<tr>
<td>B-Channel Protocol (Incoming)</td>
<td>Automatic Detection</td>
</tr>
<tr>
<td>Ignore Callback Number</td>
<td>No</td>
</tr>
<tr>
<td>Shorthold Mode</td>
<td>No</td>
</tr>
<tr>
<td>Number Checking</td>
<td>No</td>
</tr>
<tr>
<td>No-Answer Timeout (sec)</td>
<td>20</td>
</tr>
</tbody>
</table>

The ‘Property’ column identifies the property, for example ‘Callback Prefix’, ‘Shorthold Mode’, etc. The ‘Value’ column indicates the corresponding value for this property, for example ‘0’ and ‘No’.

In the properties pane, you can modify the properties of any component or binding. Depending on your configuration, some fields might be disabled because a specific property is not available or is preset by the system and cannot be modified manually.

Note: If you need to change the size of the properties pane to fully view a property, click ‘View > Split’, drag the split bar to the desired position and click the mouse button.

To view advanced properties of a component or binding:

The RAS, CAPI, TAPI, ISDN-line components and the TAPI binding have advanced properties that are not displayed in the normal view. When you need to configure advanced properties, follow the steps below:

1. Select the component or binding.
2. From the menu bar, select ‘View > Advanced’; or click the advanced button in the toolbar.
3. You can now see all basic and advanced properties in the properties pane.

To modify the properties of a component or a binding:

1. Click the component or binding you want to modify in the configuration pane.
2. Select the property you want to modify in the properties pane.
3. Type the new value for the selected property or select it from the drop-down menu.
Activating a configuration

When you change your active configuration by adding or removing a component or a binding or by modifying the properties of components or bindings, you must activate the modified configuration file for your system before the changes will take effect.

When you want to activate an existing configuration for your system, load the configuration file. To do so, click ‘File > Open’. Go to the directory where the required configuration is located. Select the configuration file and click ‘Open’.

Please note that you can only activate a configuration for your system if the Diva Server adapter(s) that you installed in the configuration manager correspond to the Diva Server adapter(s) which are physically installed in your computer.

To activate a configuration:

1. Make sure that all ISDN connections are terminated because the configuration update cannot be completed until all connections are dropped.
2. Click ‘File > Activate’; or click the activate button in the toolbar.
3. If a message appears indicating that the software has not been tested with Windows, continue the configuration update.
4. In the ‘Update Configuration’ dialog box (which indicates that the configuration update was completed successfully), click ‘OK’.
5. Restart your computer if prompted.

Saving a configuration

When you create a configuration that you do not want to use as your active configuration, save it as configuration file. If you want to use this file later on, load it and activate it for your system. If you want to make the configuration available to other users, save it in a directory to which these users have access. They can then load the configuration file and activate it for their system (provided that the Diva Server adapters that are installed in the configuration file correspond to the adapters that are physically installed in the computer).

To save a configuration:

1. From the menu bar, click ‘File > Save As’.
2. In the ‘Save as’ dialog box, specify the location and the file name.
   Click ‘Save’.
To reload your active configuration:

After you finished working on the configuration file that you do not want to use as the active configuration for your system, you can re-open your active configuration by clicking 'File > Open Active Configuration'.

Line properties

Line Type:

- **BRI (2 B-channels):**
  A basic rate line provides 2 B-channels (data) with a transfer rate of 64 kbps each and 1 D-channel (signal) with a transfer rate of 16 kbps. It can be connected to any Diva Server BRI-2M, 2FX, or Voice BRI-2M or to one port of any Diva Server 4BRI or Voice 4BRI adapter.

- **PRI (23 - 30 B-channels):**
  A primary rate line provides up to 30 B-channels (data) with a transfer rate of 64 kbps each and one D-channel (signal) with a transfer rate of 64 kbps. It can be connected to any Diva Server PRI, T1/PRI, Voice PRI, or Voice T1/PRI adapter.

- **T1 (24 channels):**
  A channelized T1 line provides up to 24 channels with a transfer rate of 56 kbps each. It can be connected to any Diva Server PRI, T1/PRI, Voice PRI, or Voice T1/PRI adapter.

Switch Type:

The switch type (D-channel protocol) depends on your ISDN switch. Your ISDN service provider can supply the required information.

The following D-channel protocols are available:

- Australia, OnRamp (ETSI-DSS1)
- Belgium, national (NET3)
- Europe/other countries, Euro-ISDN (ETSI-DSS1)
- France, national (VN3)
- Germany, national (1TR6)
• Hong Kong, Euro-ISDN (ETSI-DSS1)
• Italy/Austria, Euro-ISDN (ETSI-DSS1)
• Japan, national (INS-64)
• Japan, Euro-ISDN (ETSI-DSS1)
• PBX, Q-SIG
• Taiwan, Euro-ISDN (ETSI-DSS1)
• China, Euro-ISDN (ETSI-DSS1)
• USA/Canada, AT&T 5ESS (Custom ISDN)
• USA/Canada, Nortel DMS100 (National ISDN)
• USA/Canada, Siemens EWSD (National ISDN)
• USA/Canada, Lucent Avaya 5ESS (National ISDN)

PRI lines only:
• Sweden, Euro-ISDN (ETSI-DSS1)
• USA, AT&T Software Defined Network (4ESS)
• USA, AT&T Switched Digital Service (4ESS)
• USA, AT&T Long Distance Service (4ESS)
• USA, AT&T Megacom (4ESS)
• USA, AT&T Megacom International (4ESS)
• USA, T1 Robbed Bit Signaling (RBS)
• China, E1 - R2 Signaling (CN1)

Note: Depending on the selected switch type, line properties vary. Some parameters are available for all switch types, others only apply to specific switch types. For a description of the parameters available for your switch type, see the corresponding sections.

Interface Type:

Specify the type of interface to which the Diva Server adapter is connected. The following options are available:

Note: The ‘Interface Type’ parameter is not available for the ‘T1 Robbed Bit Signaling (RBS)’ and the ‘China, E1 - R2 Signaling’ switch types.

BRI lines:
• Point-to-Multipoint (Standard):
  Select this value if your adapter is operated on a point-to-multipoint interface. In this case, more than one terminal device can be connected to your ISDN line. Different MSNs are used to distinguish the terminal devices for incoming calls.
• **Point-to-Point:**
  Select this value if the adapter is connected to a point-to-point (NT2) interface. It is also called direct-dialing interface. It provides you an ISDN line with a basic phone number that is able to accept any extension digits and to pass them to the ISDN applications.

  **Leased:**
  Select this value if your adapter is operated on a leased line. A leased line connects two stations, e.g. two Diva Server adapters, permanently. It is reserved for the exclusive use of two stations.

Default setting for BRI lines is ‘Point-to-Multipoint (Standard)’.

PRI lines:

• **Point-to-Point (Standard):**
  Select this value if the adapter is connected to a point-to-point (NT2) interface. It is also called direct-dialing interface. It provides you an ISDN line with a basic phone number that is able to accept any extension digits and to pass them to the ISDN applications.

  **Leased:**
  Select this value if your adapter is operated on a leased line. A leased line connects two stations, e.g. two Diva Server adapters, permanently. It is reserved for the exclusive use of two stations.

Default setting for PRI lines is ‘Point-to-Point (Standard)’.

**Number Type:**

Specify which type of number you use to distinguish the ports of your line.

**Note:** The ‘Number Type’ can only be modified if you are using a BRI line. The parameter is not available if you are using a BRI line with North-American switch types, see [North-American switch types](#) on page 38.

• **MSN (Multiple Subscriber Number):**
  If you want a port to respond only to a specific call number, set up an MSN for that port. This is required, for example, if a server is set up as an extension of a PBX and can be reached only by a specific number. When using Euro-ISDN (DSS1) or any other ISDN protocol that supports Multiple Subscriber Numbering, different MSNs (up to 23 digits in length) can be used to distinguish the ports. The MSNs are provided to you by the ISDN service provider.

  In ‘MSN 1’ to ‘MSN 10’, enter the MSNs as specified by your ISDN service provider.

  **Note:** If you installed hardware and you entered MSNs for RAS during the installation of the adapter drivers, these MSNs are displayed in the ‘MSN’ fields.
• Range of Extensions:

Ranges of extensions are normally used for primary rate ISDN lines or for PBXs (Private Branch Exchanges) in Germany that use basic rate ISDN lines. Select this number type if you have a continuous range of numbers that you use to distinguish the ports.

In ‘Extension Collected by’, specify how the dialed extension digits are collected. The following options are available:

• Adapter: The adapter collects the dialed extension digits. This is the default setting.

  If you select this option, enter the lowest and highest number of your range of extensions in ‘Lowest Extension’ and ‘Highest Extension’ as specified by your ISDN service provider.

• Application: The value ‘Application’ can only be used in combination with CAPI-based applications. If you select this value, the application collects the dialed extension digits. Bindings to services other than CAPI are not allowed. This is validated and an error message is generated if necessary.

• No Phone Numbers: If you select this option, the Diva Server adapter immediately signals an incoming call to the services or applications, without collecting the MSNs or extension digits. It is up to the services or applications to detect whether dialing is finished and the incoming call should be answered.

  This option might be useful if your switch is not able to signal MSNs or extension digits.

**North-American switch types:**

• ISDN Number 1 / ISDN Number 2:

  Enter your ISDN numbers for SPID 1 and SPID 2 as specified by your ISDN service provider.

• SPID Mode:

  Specify how the SPIDs (Service Profile Identifiers) are set for your line. Your ISDN service provider can supply the required information.

  • Automatic SPID Assignment: Select this option if your ISDN switch supports AutoSPID. AutoSPID allows your adapter to detect the SPIDs automatically. You do not need to enter them manually when initializing the ISDN line.

  • No SPIDs: Select this option if your ISDN switch does not require SPIDs to enable ISDN services.

  • Configure SPIDs: Select this option to specify the SPIDs that the driver has to use to communicate with the switch. Enter your SPID numbers in ‘SPID 1’ and ‘SPID 2’.

  **Note:** If you installed hardware and you entered SPIDs and ISDN numbers for RAS during the installation of the adapter drivers, these numbers are displayed in the respective fields.
Q-Sig specific line parameters

Q-Sig is the standard protocol for inter-PBX signaling. If you are using a Q-Sig switch type, you must configure the following specific parameters.

For information on proper Q-Sig settings, refer to your PBX documentation.

PBX Type:

Select your PBX type from the list. If your PBX is not listed, select ‘Generic’.

Q-Sig Standard:

Normally, the correct Q-Sig standard is automatically set for the selected PBX type. Change this value only if your PBX requires a different value.

Call Reference Format:

Select the ‘Call Reference Format’ for your PBX type. The ‘Standard’ format uses two bytes for the call reference and the ‘Short’ format uses one byte.

‘Call Reference Format’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding: on page 33.

Channel Identifier Format:

For BRI lines only. Select the ‘Channel Identifier Format’ for your PBX type. The ‘Standard’ format uses the PRI format, i.e. three bytes, for the channel identifier and the ‘Short’ format uses one byte.

‘Channel Identifier Format’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding: on page 33.

Channel Assignment:

For PRI - E1 lines only. Specify if your PBX uses channel assignment according to time slots or continuous numbering. Normally, the correct ‘Channel Assignment’ is automatically set for the selected PBX type.

An E1 line has 32 time slots. Time slot 0 is used for synchronization. Time slots 1 to 15 are used by the first fifteen physical B-channels. Time slot 16 is used by the D-channel and time slots 17 to 31 are used by the next fifteen B-channels.

If your PBX assigns the channel ID according to time slots, the ID is identical to the time slot that the B-channel uses. If your PBX numbers the B-channels continuously, the channel ID is not identical to the used time slot. For example, channel ID 16 corresponds to time slot 17.
Since the applications assume that the channel IDs are identical to the used time slots, the line must provide an interpretation of the numbers for continuous numbering to ensure correct switching of the B-channels.

‘Channel Assignment’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding: on page 33.

**Specific parameters for T1 Robbed Bit Signaling (RBS)**

Channelized T1 Robbed Bit Signaling is designed for Extended Superframe (ESF) framing and channel format. If you are using the T1 RBS switch type, you must configure the following specific parameters:

**Trunk Type:**
The trunk type in the Diva Server configuration manager has to correspond to the trunk type of your switch. Select one of the following options:

- WinkStart
- LoopStart
- GroundStart

Default setting is ‘WinkStart’.

**Note:** All trunk types are defined in the specification TIA/EIA-464B; the trunk type ‘WinkStart’ is also defined in AT&T TR41458.

**Answer Supervision**
For ‘GroundStart’ and ‘LoopStart’ trunk types only. ‘Answer Supervision’ detects when the remote side answers a call and thus ensures accurate billing of a call. If ‘Answer Supervision’ is disabled, the standard connection detection based on tones is used.

**Signal Mode**
For ‘GroundStart’ and ‘LoopStart’ trunk types only. Signaling can be done using the foreign exchange mode (FXO/FXS) or the special access mode (SAS, SAO). A foreign exchange station (FXS) is simply a device connected to a PBX. It is controlled by the local PBX and the remote switch at the central office. When the device is connected to the central office through a PBX, the central office is called a foreign exchange office (FXO). The special access is a dedicated line through the central office going directly to a long-distance carrier.

The signaling mode that you select here must correspond to the setting of your switch or carrier. Your telco company can supply the required information.
Dial Type

The dial type in the Diva Server configuration manager has to correspond to the dial type of your switch. Select one of the following options:

- Pulse
- DTMF (Dual-Tone Multifrequency Signaling)
- MF (Multifrequency Signaling)

Default setting is ‘DTMF’. Most analog telephones use dual-tone multifrequency signaling.

Direct Inward Dialing:

For TE mode only. Use the ‘Direct Inward Dialing’ option to specify how an incoming call is handled.

- No: An incoming call is accepted and forwarded as soon as the destination party indicates off-hook status. The incoming dialed digits are not collected and the dialed number is not forwarded.
- Yes: The incoming dialed digits are collected. When all dialed digits are received, a CONNECT indication is sent to the application and the connection is established.

The default setting is ‘Yes’.

Note: Make sure that the settings for ‘Direct Inward Dialing’ on your switch and in the Diva Server configuration manager correspond to each other. Otherwise, the connection will become extremely slow.

‘Direct Inward Dialing’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding on page 33.

Glare-resolving Party:

If both ends of a line simultaneously attempt to initiate a call, a call collision occurs. Specify in ‘Glare-resolving Party’ how a collision is resolved.

- No: When a call collision occurs, your server will not abort its call attempt to resolve the collision but will wait for the other party to do so. It will then start sending address digits.
- Yes: When a call collision occurs, your server will stop dialing and return to on-hook status. It will prepare to receive address digits and the call attempt from the other end of the line can be completed.

The default setting is ‘Yes’ for ‘Terminal Endpoint’ mode and ‘No’ for ‘Network Termination’ mode.

‘Glare-resolving Party’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding on page 33.
Signal Calls as:

Specify in ‘Signal Calls as’ which bearer capability should be included with the incoming call that is signaled to the application.

- Voice/Analog (3.1 kHz audio µLaw): Select this value if your application is meant to accept voice calls, fax group III calls, and analog modem calls.
- Data/Digital (56 kbps rate adaptation HDLC): Select this value if your application handles digital calls, e.g. digital RAS.

Note: If your switch can support only voice (analog) or data (digital) calls at one time, make sure that it is configured to correspond with the ‘Signal Calls as’ value.

‘Signal Calls as’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding; on page 33.

Answer Timeout:

In ‘Answer Timeout’, set the time interval, in seconds, after which the adapter hangs up if the remote station does not answer a call. Default setting is 120 seconds.

‘Answer Timeout’ is an advanced parameter. For information on displaying advanced parameters see To view advanced properties of a component or binding; on page 33.

Advanced line parameters for all switch types

To configure advanced line parameters, select ‘View > Advanced’; or click the advanced button in the toolbar.

Voice Coding:

Voice coding defines how voice data is transmitted over the ISDN. The following options are available:

- Protocol Default
- Force a-Law (generally used in Europe)
- Force µ-Law (generally used in North America)

Default setting is ‘Protocol Default’. This sets automatically the correct voice coding for the selected switch type.

In most cases you can leave ‘Voice Coding’ at its default value. Only if a PBX requires special voice coding which does not correspond to the voice coding of the switch type, you need to change the setting.
Operation Mode:

In ‘Operation Mode’, specify whether you want to operate your Diva Server adapter as ‘TE - Terminal Equipment’ on a PBX or the PSTN or as internal ‘NT - Network Termination/Switch’.

Note: NT mode is only supported by Diva Server PRI, PRI 2.0, T1/PRI, Voice PRI, Voice T1/PRI, 4BRI-8M 2.0, Voice 4BRI-8M 2.0, BRI-2M 2.0, and Voice BRI-2M 2.0 adapters.

 Normally, Diva Server adapters are operated as terminal equipment. As terminal equipment, they derive their timing from the signal received from the NT, e.g. PSTN or PBX, and use this derived timing to synchronize their transmitted signal.

If you use the Diva Server adapter as network termination, it generates the timing from which the terminal equipment derives its timing and synchronization.

Using the Diva Server adapters as NT might be useful in a diverse range of applications:

• Diva Server adapters in network termination mode serve as master in PBX networks that use the Q-Sig protocol. This is the main field of application.

• Two Diva Server adapters are operated back-to-back. Back-to-back operation allows you to set up network-independent test scenarios for trade shows and to run stress and long-time tests for application software.

• Diva Server adapters are used as test or measuring device by running test scripts with third-party software that supports network emulation.

• Standard terminal equipment such as telephones or terminal adapters are connected to the Diva Server adapter. Note, however, that you must use an external S0 power supply from a third-party manufacturer if you operate the Diva Server adapter in combination with terminal equipment that requires power feeding.

For information on properly connecting Diva Server adapters acting as an NT to the respective TEs, see the printed guide that came with your Diva Server adapter.

Fractional T1/E1 Line:

PRI or T1 lines only. Specify here if you use a fractional T1 or E1 line.

• If you use a full E1 or T1 line offering 30, 23, or 24 B-channels, select ‘No’.

• If you use a fractional T1 or E1 line, select ‘Yes’. Indicate the number of B-channels that your line offers in ‘Number of Available B-Channels’. Also, indicate the lowest channel assigned to your line in ‘Lowest B-Channel’.

Note: If you select ‘Yes’, you should check the number of B-channels that are assigned to each service in the binding properties and change these settings if necessary (see Number of B-Channels; on page 64).
**Number of Available B-Channels:**

This parameter is only available if ‘Fractional T1/E1 Line’ is set to ‘Yes’.

Indicate the number of B-channels that your fractional E1 line offers.

If ‘Number of Available B-Channels’ corresponds to the number of DSPs on your Diva Server PRI adapter, any combination of simultaneous calls, digital, analog, or GSM, is possible. If ‘Number of Available B-Channels’ exceeds the number of DSPs on your Diva Server PRI adapter, two DSPs are exclusively reserved for digital calls. Thus, the number of analog or GSM connections that can be established simultaneously is reduced by two (see also Digital Signal Processors: on page 50).

**Lowest B-Channel:**

This parameter is only available if ‘Fractional T1/E1 Line’ is set to ‘Yes’.

Specify the lowest B-channel that is assigned to your fractional E1 line. Your ISDN service provider can supply the required information.

The Diva Server adapter always assigns the first connection to the specified ‘Lowest B-Channel’.

**Generate Ring Tones:**

For NT mode or point-to-point connections only. Normally, ring tones are generated by the switch or PBX. If the switch or PBX do not provide busy or alert tones for incoming calls, set ‘Generate Ring Tones’ to ‘Yes’ to enable the Diva Server adapter to generate these tones.

**Device Mode:**

This parameter is only available if your Diva Server adapter is connected to the CAPI service.

In ‘Device Mode’, specify in which mode your Diva Server adapter is operated. The following options are available:

- **Standard:**
  Select this option if you use the Diva Server adapter in a standard environment.
• Monitoring:
Select this option if you use the Diva Server adapter in combination with monitoring software to monitor the frame and data flow on the D-channel and B-channel during a connection. In this case, the Diva Server is set to high-impedance state in order not to disturb the actual connection.

• Hunt group:
Select this option if your Diva Server adapter is operated in a hunt group. In a hunt group, it might be necessary to disable the line as long as no application can service the calls to avoid losing calls.

If you select ‘Hunt Group’, your Diva Server adapter is set to high-impedance state which means that the PBX considers the adapter’s line as not being connected and does not deliver calls to it. When an application signals that it is ready to service a call, the Diva Server adapter switches to normal operation mode. The PBX is signaled that the adapter is connected to a port and that calls can be routed to it. If the application is terminated or fails, the Diva Server adapter returns to high-impedance state and is no longer available to the PBX.

Advanced line parameters for all switch types except T1-RBS and E1 - R2 Signaling

To configure advanced line parameters, select ‘View > Advanced’; or click the advanced button in the toolbar.

Direct Dial In (NT2):
This parameter is normally preset according to the selected interface type. It needs to be considered rarely and only in conjunction with some ISDN switch assemblies. Default setting is ‘No’ for the point-to-multipoint interface type and ‘Yes’ for the point-to-point interface type.

Note: If you are using a BRI line and a North American switch type the ‘Direct Dial In (NT2)’ parameter is not available.

TEI:
This parameter specifies the ‘TEI’ (Terminal Endpoint Identifier) that is assigned to the ISDN line. Leave the setting as preset by the system unless your ISDN service provider specifies a different TEI for your connections.

For point-to-multipoint connections, the default setting is ‘Automatic’. For point-to-point connections, the default setting is ‘0’. 

Configuration Manager
Layer 2 Connect Mode:
The ‘Layer 2 Connect Mode’ controls the D-channel layer 2 connection mode. Select one of the following options:

- On Demand: The D-channel layer 2 control connection is activated to establish the B-channel data connection and is deactivated as soon as the B-channel data connection releases.
- No Disconnect: The D-channel layer 2 control connection is activated when a B-channel data connection is established for the first time and is kept active afterwards.
- Permanent: The D-channel layer 2 control connection is activated as soon as the ISDN D-channel protocol is loaded and is kept active afterwards.

Default setting for BRI lines is ‘No Disconnect’, for PRI lines ‘Permanent’. Leave the setting as preset by the system unless your ISDN service provider specifies a different setting for your switch type.

Note: North-American protocols and PRI lines always require the setting ‘Permanent’.

Line Mode:
In ‘Line Mode’, specify whether your adapter is used in a ‘Switched’ or a ‘Leased Line’ environment. In a switched environment, the connection between two stations is only established on demand and held until no longer required. In a leased environment, two stations are connected permanently. Default setting is ‘Switched’.

CRC 4 Mode:
Specify how the information element CRC 4 is handled. The following options are available:

- Protocol Default: CRC 4 is handled as described in the respective ISDN D-channel protocol specification.
- Force Off: CRC 4 is not transmitted.
- Force On: CRC 4 is always transmitted.

Default setting is ‘Protocol Default’.

In most cases you can leave the CRC 4 parameter at its default value. Occasionally, the CRC 4 element is not implemented and therefore needs special processing.

Specific advanced parameters for E1 - R2 signaling
To configure advanced line parameters, select ‘View > Advanced’; or click the advanced button in the toolbar.
Signal Calls as:

Specify in ‘Signal Calls as’ which bearer capability should be included with the incoming call that is signaled to the application.

- Voice/Analog (3.1 kHz audio µLaw): Select this value if your application is meant to accept voice calls, fax group III calls, and analog modem calls.
- Data/Digital (56 kbps rate adaptation HDLC): Select this value if your application handles digital calls, e.g. digital RAS.

Note: If your switch can support only voice (analog) or data (digital) calls at one time, make sure that it is configured to correspond with the ‘Signal Calls as’ value.

Specific advanced parameters for North-American switch types in combination with BRI lines

To configure advanced line parameters, select ‘View > Advanced’; or click the advanced button in the toolbar.

Force Alert:

If you enable the ‘Force Alert’ option, the Diva Server adapter sends an ALERT instead of a DISCONNECT message when a call comes in while no application is active or the computer is being restarted. In this case, the voice mail system answers the call instead of it being disconnected immediately.

Configure EKTS (Electronic Key Telephone Service):

Some North-American switch types require feature activators to be able to provide supplementary services, such as call transfer or conference, for BRI lines. If you ordered supplementary services for your line, specify the feature activators as indicated by your ISDN service provider. To do so, set the ‘Configure EKTS’ option to ‘Yes’.

You can now configure the following parameters:

- Display Values as

  Normally, the feature activator values are displayed as decimal figures. If you require a hexadecimal format, set the ‘Display values as’ option to ‘Hexadecimal’.

- Add to Conference

  The ‘Add to Conference’ feature allows you to start a conference or to add a new participant to a conference.

  Enter the value that activates this feature for your switch type. Typical values for the ‘Add to Conference’ feature activator are ‘61’ for the ‘Nortel DMS 100’ and ‘60’ for the ‘Lucent Avaya 5ESS’ switch types.
• Remove from Conference

The ‘Remove from Conference’ feature allows you to disconnect the last participant who joined a conference.

Enter the value that activates this feature for your switch type. Your ISDN service provider can supply the required information. Typical values for the ‘Remove from Conference’ feature activator are ‘63’ for Nortel DMS 100 and ‘62’ for Lucent Avaya 5ESS.

• Call Transfer

The ‘Call Transfer’ feature allows you to connect two calls and disconnect yourself from the call.

Enter the value that activates this feature for your switch type. Typical values for the ‘Call Transfer’ feature activator are ‘62’ for Nortel DMS 100 and ‘61’ for Lucent Avaya 5ESS.

• Message Waiting

The ‘Message Waiting’ feature indicates if the voice mail system has recorded a message.

Enter the value that activates this feature for your switch type. A typical value for the ‘Message Waiting’ feature activator is ‘50’ for Nortel DMS 100 and Lucent Avaya 5ESS.

• Call Appearances

Enter a value for ‘Call Appearances’ to activate the CACH (Call Appearance Call Handling) feature that allows you to handle more than one call on an individual device. The ‘Call Appearance’ value corresponds to the number of indicator lamps that signal incoming calls. The maximum value is ‘20’. 
Adapter properties

**Adapter Name:**

The 'Adapter Name' parameter displays the name of your adapter, e.g. Diva Server BRI-2M PCI.

**Description:**

The 'Description' gives information on the ports that the installed Diva Server adapter offers.

- 1 BRI port (2 B-channels): The Diva Server BRI-2M PCI and ISA, BRI-2M 2.0, and 2FX adapters offer one BRI port.
- 1 BRI port (2 B-channels) + voice: The Diva Server Voice BRI-2M 2.0 adapter offers one BRI port.
- 4 BRI ports (4 x 2 B-channels): The Diva Server 4BRI-8M and 4BRI-8M 2.0 offer four BRI ports.
- 4 BRI ports (4 x 2 B-channels) + voice: The Diva Server Voice 4BRI-8M and Voice 4BRI-8M 2.0 offer four BRI ports.
- 1 PRI/T1/E1 port (23-30 B-channels): Any Diva Server PRI or T1/PRI adapter offers one PRI port for connection to an ISDN PRI or a channelized T1 interface.
• 1 PRI/T1/E1 port (23-30 B-channels) + voice: Any Diva Server Voice PRI or Diva Server Voice T1/PRI adapter offers one PRI port for connection to an ISDN PRI or a channelized T1 interface.

Bus Type:
The bus type is automatically set according to the adapter type that you installed or added to your configuration.

• ISA: for the Diva Server BRI-2M ISA-bus adapter.
• PCI: for all Diva Server adapters except the Diva Server BRI-2M ISA-bus adapter.

Bus Number:
If your computer has more than one bus, the bus number indicates on which bus the Diva Server adapter is operated.

Lines:
‘Lines’ indicates the number of lines that are available for a Diva Server adapter. This number is automatically set according to your adapter type. It ranges from 1 to 4.

Serial Number:
The serial number is automatically read from the adapter.

Digital Signal Processors:
‘Digital Signal Processors’ indicates the number of digital signal processors (DSPs) that are available on your Diva Server adapter.

The number of DSPs on your Diva Server adapter determines the number of simultaneous analog or GSM connections that can be established with your adapter. This is especially important for Diva Server PRI adapters.

If the number of DSPs on your Diva Server PRI adapter corresponds to the number of B-channels that your PRI or T1 line offers, all DSPs are available for analog and GSM connections and digital connections are also possible. This means, for example, that a Diva Server PRI-30M adapter used on a regular E1 line can establish 30 simultaneous connections and any combination of digital, analog, or GSM calls is possible.

If the number of DSPs on your Diva Server PRI adapter is lower than the number of B-channels that your line offers, two DSPs are exclusively reserved for digital calls and cannot be used for analog or GSM connections. This means, for example, that a Diva Server PRI-8M adapter used on a regular E1 line can establish only six simultaneous analog or GSM connections.
RAS properties

The Remote Access Service of Windows 2000 or Windows XP lets remote clients access corporate Windows 2000 or Windows XP servers using an ISDN BRI or PRI line or a channelized T1 line.

**Total RAS Ports:**

The parameter ‘Total RAS Ports’ displays the number of ports that are made available to the RAS for communications. The number depends on the B-channels that you make available to this service. You can set the number in the properties of the binding(s) for this service.

**Callback Prefix:**

Specify a ‘Callback Prefix’ if you need to insert one or more digits in front of the callback numbers for all clients. This is required in the following situations:

- The server is operated behind a PBX, which requires a certain prefix, e.g. 9, when it dials out to the public ISDN line. The ‘9’ can be automatically included in the callback when dialing.
- The Euro-ISDN protocol suppresses the leading zero when sending. Therefore, the server will normally not be able to call the client back in shorthold mode (see also Shorthold on page 95). With the callback prefix ‘0’, the complete call number is dialed.

**Advanced parameters for RAS**

To configure the advanced parameters for RAS, select ‘View > Advanced’; or click the advanced button in the toolbar. You can now configure the following properties:

**Use Defaults for Callback:**

Set ‘Use Defaults for Callback’ to ‘Yes’ to use the default bearer capability (analog or digital) for all outgoing calls (callbacks) regardless of the bearer capability of the incoming call. Default setting is ‘No’.

Normally, if a call comes in and is identified as a callback request, all call parameters are stored and used for the outgoing call. In special cases, e.g. in certain PBX environments, this does not work because the PBX can only deal with default bearer capabilities and not
with the extended capabilities that might have been signaled. If ‘Use Defaults for Callback’ is set to ‘Yes’, the bearer capability of the incoming call is ignored and the default bearer capability is used for the callback.

**B-Channel Protocol (Incoming):**

The ‘B-Channel Protocol (Incoming)’ parameter is not available for Diva Server 2FX adapters.

Normally, the WAN Miniport detects the B-channel protocol of incoming calls automatically and the default setting ‘Auto detection’ may stay unchanged. However, the Chinese PIAFS B-channel protocol cannot be auto-detected. If incoming calls use this protocol, you must specify the appropriate PIAFS version:

- PIAFS (China, fixed speed):
  Select this option if the PIAFS B-channel protocol of your incoming calls uses a fixed transfer rate, either 64 kbps or 32 kbps. Specify the transfer rate under ‘B-channel protocol speed’.

- PIAFS (China, speed detection):
  The transfer rate used by your PIAFS B-channel protocol is automatically detected. Select this option only if your incoming PIAFS calls use variable transfer rates because speed detection might slow call establishment down.

**Note:** If you want to use PIAFS for outgoing calls, you have to indicate it as an extension to the number to be dialed. See page 83 for further information.

**Ignore Callback Number:**

**Note:** This parameter is only relevant if you use your computer also in client mode.

Set ‘Ignore Callback Number’ to ‘Yes’ if you want the WAN-Miniport driver to accept any callback even if the number of the calling RAS server does not match the number that the RAS client called when asking for a callback. Default setting is ‘No’.

It might be useful to enable this option if the RAS server that you ask for callback is operated behind a PBX that hides the complete calling number or part of it when calling you back. In that case the number you dialed does not match the calling party number of the callback. Thus, you will only be able to accept the callback if you have ‘Ignore Callback Number’ enabled.

**Shorthold Mode:**

The Diva Server for Windows 2000/XP shorthold is an Eicon WAN-Miniport option and therefore only functions between two computers equipped with Eicon Diva adapters.

Set this option to ‘Yes’ to automatically break the physical ISDN connection when the configured shorthold time has been exceeded with no transmission of data. As soon as new data is available for transmission, the physical connection is established again (see also Shorthold on page 95).
If the ‘Shorthold Mode’ option is enabled but the ‘Shorthold Time’ is ‘0’, the driver will never initiate a shorthold of its own accord, though shortholds requested by the remote station will be accepted.

If the ‘Shorthold Mode’ option is disabled, the driver will not initiate a shorthold nor will it accept shorthold requests from the remote station.

**Shorthold Time (sec):**

This parameter is only available when ‘Shorthold Mode’ is enabled.

Specify the period (in seconds) that a line must be idle before the physical link is disconnected. Shorthold time = 0 means that the computer will not disconnect itself but will accept shorthold requests from the remote station.

**Number Checking:**

This option enables you to have incoming calls checked by the WAN-Miniport driver. If you set ‘Number Checking’ to ‘Yes’, an incoming call is only accepted if it matches an entry in the ‘Number Check File’. Calls with other telephone numbers are rejected immediately without notifying RAS. If you know all possible locations of clients who have dial-in permission, you can gain additional protection against misuse of the server by using the number checking feature.

**Note:** If ‘Number Checking’ is enabled a ‘Number Check File’ must exist, otherwise an error is reported.

**Number Check File:**

This parameter is only available when ‘Number Checking’ is enabled.

Enter the path to the configuration file which contains the call numbers authorized by RAS, e.g. C:\DATA_FILES\EICON\NUMBER_CHECKING.CFG.

**Note:** The configuration file for number checking is read only when the driver is started. Therefore, changes to the file take effect only after restarting the computer.

Example: Configuration file for call number checking

```
; Configuration Example
765765
765766
8154711^08154711
8154712^08154712
; In Euro-ISDN, leading zeros in the telephone number
; are cut off
3334444^993334444
3334445^993334445
; ‘99’ preset for answering
123456|789^99123456|789
; With subaddress ‘789’
; commented out
```
Every entry must be the telephone number of a terminal. If a subaddress (SUB) needs to be entered, it must be separated from the remainder of the call number by a vertical character [\] (also called the pipe symbol).

You can specify the callback number for the connection on the same line as the telephone number, separated by a [^]. If a subaddress (SUB) needs to be entered, it must be separated from the rest of the call number by a vertical character [\] (also called the pipe symbol).

**Note: Pipe symbol**
The pipe symbol can be typed directly from English keyboards, or by holding [Alt] down and entering [0], [1], [2], [4] on the numeric keypad.

A callback number must always be specified if the shorthold mode is activated and the telephone number sent by the exchange does not conform to the number of the remote station.

Example: In EURO-ISDN, the exchange cuts off the leading zeros, which means the attempt to re-establish the connection after a shorthold fails. A similar problem occurs if the Diva Server adapter is operated on an extension that requires a specific sequence of digits to answer.

Each entry must be on a separate line.

Empty lines are ignored.

If a semicolon [;] is placed at the beginning of a line, all subsequent characters until the end of the line are ignored. This can be used to place comments next to call numbers.

A maximum of 1000 entries may be included, corresponding to 1000 configured call numbers.

**Creating a number check file with the remote access policies of Windows 2000**

If you have enabled and configured the Remote Access of Windows 2000 for your computer (see RAS server setup on page 88), you can also use the Windows 2000 remote access policies to create a number check file:

**Note:** Since Windows XP Professional does not allow to set up a RAS server for a large number of incoming calls, the following section only describes how to create a number check file with the remote access policies of Windows 2000.

- Click ‘Start > Programs > Administrative Tools > Routing and Remote Access’.
- In the ‘Routing and Remote Access’ window, click the ‘+’ next to the entry for your computer to expand the tree.
- In ‘Add Remote Access Policy’, type a name for your number check file and click ‘Next’.
- In the displayed dialog box, click ‘Add’.
- In the ‘Select Attribute’ dialog box, select ‘Calling-Station-ID’ and click ‘Add’.
In the ‘Calling-Station-ID’ dialog box enter the telephone number to which you want to grant remote access permission to your server. Click ‘OK’.

Enter all numbers to which you want to grant access to your server. When you are done, click ‘Next’.

In ‘Add Remote Access Policy’ select ‘Grant remote access permission’ and click ‘Next’.

In the displayed dialog box, specify the user profile if required. Click ‘Finish’.

For further information see your Windows 2000 documentation.

**No-Answer Timeout (sec):**

In ‘No-Answer Timeout (sec)’, set the time interval, in seconds, after which the WAN Miniport hangs up if the remote station does not answer a call. Any value between 2 and 20 seconds is allowed. Default setting is 20 seconds.

### Modem properties

- **Analog**
- **Fax**
- **V.120**
- **Server**
- **Digital**
- **X.75**
- **V.110**
- **X.25**

Diva Server for Windows 2000/XP provides the Eicon Port driver, i.e. virtual COM port, for modem emulation. It behaves like a serial interface with a connected modem. You can install a modem or a modem pool in the configuration manager and select the serial COM ports on which the modems are to be installed. The Eicon Port driver of Diva Server for Windows 2000/XP allows you to install virtual modems for a variety of connections: fax, V.110, V.120, HDLC, X.75, X.25, or analog modem. Thus, you can send and receive faxes, access ISDN mailboxes, or communicate with analog modems.

If you are using an application that is not TAPI-based and therefore needs to address the Eicon Port driver directly, see the section Eicon Port Driver on page 71.

**Note:** If you have enabled the Windows 2000 remote access server for your server, every virtual Eicon ISDN modem that you install afterwards is automatically configured for usage by RAS. If you want to use your modem for another service, you need to disable the usage of this modem by RAS:
• Select ‘Start > Programs > Administrative Tools > Routing and Remote Access’.
• In ‘Routing and Remote Access’, right-click ‘Ports’ from the details pane and select ‘Properties’.
• In the ‘Ports Properties’ dialog box select the Eicon modem for which you want to disable usage by RAS and click ‘Configure’.
• In the displayed dialog box, disable ‘Remote access connections (inbound only)’. Click ‘OK’.
• Click ‘OK’ to close the ‘Ports Properties’ dialog box.

Modem Name:

The following modems are available:

• Eicon Diva Analog Modem: Install this modem for analog data communications to analog modems over ISDN.
• Eicon Diva Fax Modem: Install this modem for sending and receiving faxes of fax group III.
• Eicon Diva V.120 Modem (64K): Install this modem for CompuServe access over ISDN and for some ISDN mailboxes.
• Eicon Diva V.120 Modem (56K): Install this modem for CompuServe access over ISDN and for some ISDN mailboxes.
• Eicon Diva V.110 Modem: Install this modem for low-speed connections over ISDN, e.g. for RAS connections and data transfer via GSM.
• Eicon Diva X.25 Modem: Install this modem for connections to devices such as credit card terminals, POS, or others that use dial-up connections and require the X.25 protocol for communication. When this modem is installed, a credit card terminal, for example, is able to call the Diva Server adapter directly and the two devices communicate using the X.25 protocol in the B-channel. Note that you can only establish one permanent virtual connection per channel if you use the Diva X.25 Modem.
• Eicon Diva X.75 Modem (64K): Install this modem for connections to some mailbox bulletin board systems in Europe.
• Eicon Diva X.75 Modem (56K): Install this modem for connections to some mailbox bulletin board systems in Europe.
• Eicon Diva PPP-Modem (64K): Install this modem for digital ISDN connections with a transfer rate of 64 kbps.
• Eicon Diva PPP-Modem (56K): Install this modem for digital ISDN connections with a transfer rate of 56 kbps.
• Eicon Diva Generic Server Modem: This modem is designed for incoming calls only. It supports automatic B-channel call distribution which means that it can distinguish incoming calls according to service and protocol and distribute each call to the
corresponding application (e.g. fax or data). Nevertheless, callback is possible with the Eicon Diva Generic Server Modem. It should be used for a dial-in server with different kinds of remote counterparts.

The Eicon Diva Generic Server Modem is preset to the following parameters:

- It accepts analog calls.
- It allows callback. This means it supports RAS callback. In the RAS callback scenario, the remote user is automatically disconnected after authentication and then called back. The properties of an incoming call are registered and the same properties are applied to the outgoing callback.
- It accepts incoming calls with synchronous PPP. Synchronous PPP is an ISDN-specific framing method that is used by ISDN networking products.

Notes:

- The suffixes ‘(56K)’ or ‘(64K)’ determine the transfer rate for the virtual modems. Some regions in the USA only support 56 kbps. For connections to such remote terminals, you have to select the 56K version of a modem.
- Diva Server 2FX adapters support the following virtual modems: Eicon Diva Fax Modem, Eicon Diva V.110 Modem, Eicon Diva V.120 Modem (64K), Eicon Diva PPP-Modem (64K), Eicon Diva X.75 Modem (64K), Eicon Diva X.25 Modem, and Eicon Diva Generic Server Modem.

Attached to COM Port:

In 'Attached to COM Port', specify the port on which a modem is to be installed, e.g. COM 5.
Modem pool properties

If you need more than one modem of a specific modem type, you can configure a pool of modems instead of adding single modems.

**Note:** You can convert an installed single modem into a modem pool. To do so, right-click the modem and select ‘Convert to Pool’ in the pop-up menu. The number of B-channels that are assigned to the modem pool stays unchanged. Thus, the number of B-channels does not necessarily correspond to the number of modems.

**Modem Name:**

All modems that you can install as single modems can also be installed as modem pools. For a list of available modems, see [Modem Name](#) on page 56.

**Number of Modems:**

In ‘Number of Modems’, specify the number of modems that your pool should contain. If you are using a Diva Server PRI adapter, you can add up to 30 modems to your pool.

**First COM Port:**

In ‘First COM Port’, select the port on which the first modem is to be installed, e.g. COM 13.

**Last COM Port:**

‘Last COM Port’ is automatically set and specifies the port on which the last modem is installed. The ports are counted consecutively from the first port upwards.
The CAPI (Common Application Programming Interface) is a standardized software interface that enables communication applications to communicate with ISDN adapters.

The CAPI 2.0 driver makes the supported Diva Server adapters available for ISDN-based applications that use the CAPI 2.0 interface. It is compatible with the CAPI 2.0 (Common Application Programming Interface), a standard software interface.

**Total CAPI Controllers:**

Applications that use CAPI 2.0 can use the CAPI 2.0 driver to access various controllers numbered from 1 to n. Every controller provides a basic-rate or a primary-rate access to the ISDN.

In ‘Total CAPI Controllers’, the number of controllers that are made available to the CAPI service is displayed.

**Advanced parameters for CAPI**

To configure advanced parameters for CAPI, select ‘View > Advanced’; or click the advanced button in the toolbar. You can now configure the group optimization:

**Group Optimization**

Group optimization enables the Diva Server adapter to create application groups depending on the LISTEN parameter that each application passes to the adapter. Every incoming call is distributed on a per-group basis instead of a per-application basis. Thus, only one idle application in a group and not every idle application that matches the incoming call receives the indication about the call.

If the acceptance of incoming calls under heavy load shows failures, enabling ‘Group Optimization’ may improve the situation. The parameter should also be enabled for applications that use multiple CAPI registrations. It should not be enabled for applications that are able to service all B-channels with one CAPI registration.
TAPI properties

The Diva Server Telephony Service Provider (TSP) provides a TAPI interface for the Diva Server adapters.

The TAPI (Telephony Application Programming Interface) offers the possibility of Computer Telephony Integration (CTI) for Microsoft operating systems. The TAPI is only responsible for establishing and terminating a connection. The media stream in a connection is controlled by a wave/audio driver. The Diva Server Telephony Service Provider includes the Eicon Wave driver that controls the media stream. It also includes a DSI module that is responsible for transferring voice data between the TSP and the wave driver. Based on this, TAPI applications such as Interactive Voice Response, Automatic Call Distribution, etc. can be used.

Available TAPI Lines: (formerly ‘Total TAPI Ports’)

‘Available TAPI Lines’ specifies the number of connections that you can simultaneously establish for the Diva Server TSP. The number depends on the lines that you make available to this service. You can set the number of available TAPI lines in the properties of the binding(s) for this service.

Prefixes:

Specify whether prefixes should be added to the caller number for calls to the TAPI application. If you select ‘User Defined’, you can specify the following prefixes:

- **PBX Prefix for All Calls:**
  If you are working behind a PBX, enter the prefix that is required for an external line in ‘PBX Prefix for All Calls’, e.g. ‘9’. This prefix will be added to the caller number for all calls to the TAPI application.

- **Area Code Prefix for National Calls:**
  In ‘Area Code Prefix for National Calls’, enter the prefix that should be added to the area code for all national calls, e.g. ‘0’. This prefix will be added to the caller number for national calls to the TAPI application.

- **Country Code Prefix for International Calls:**
  In ‘Country Code Prefix for International Calls’, enter the prefix that should be added to the country code for all international calls, e.g. ‘001’. This prefix will be added to the caller number for international calls to the TAPI application.
The Diva Server TSP always adds the PBX prefix (if enabled) and adds either the national or the international prefix (if enabled) depending on the call. For example, using the prefixes given above, a call with the international number 4317711 would be offered to the TAPI application as 9 001 4317711.

**Maximum Number of Calls on Hold:**

In ‘Maximum Number of Calls on Hold’ enter the number of calls that can be put on hold. If the number of incoming calls exceeds this value, all additional calls are directly rejected.

**Wave: Performance Options:**

Specify for which kind of performance your TSP should be optimized. The following options are available:

- **Performance Optimized:**
  If you select this option, your TSP is able to handle the maximum number of calls in parallel but the time required for data transfer is high.

- **Minimum Delay:**
  Select this option if you require a very fast data transfer and you do not need to handle a large number of calls in parallel.

- **Short Delay Good Performance:**
  Select this option to get the best possible mix of good performance and fast data transfer.

- **User Defined:**
  Select the ‘User Defined’ option to set your own values for all parameters that influence the performance. You can set the following values:

  - **Buffer Size:** Voice data are transferred between the adapter, the Diva Server TSP, and the Eicon Wave driver. Each of these three components use buffers to store data that cannot be processed immediately. To optimize processing performance, the buffer size and the number of buffers that each component uses can be configured. In ‘Buffer Size’ indicate the buffer size in bytes.

  - **Buffers per Channel:** Each channel can reserve its individual buffers to store voice data that cannot be processed immediately. In ‘Buffers per Channel’ indicate the number of buffers that should be assigned to each channel.

  - **Wave Factor to Buffers per Channel:** The wave driver is able to reserve a multiple of the buffers that the adapter or the Diva Server TSP reserve. In ‘Wave Factor to Buffers per Channel’, indicate the factor by which the buffers should be multiplied. The actual number of buffers reserved by the wave driver is the product of this factor and the value for ‘Buffers per Channel’.
Logging:

Specify in ‘Logging’ which messages should be logged by the Eicon maintenance driver. Select one of the following logging options:

- None:
  No errors, warnings, or status messages are logged.
- Standard:
  All errors are logged.
- Interface calls:
  All errors and function calls from the modules’ interfaces are logged.
- User defined:
  Select ‘User Defined’ to set specific logging levels for each module, the TAPI Service Provider, the wave driver, and the DSI module. You can select no logging, logging of interface calls, standard logging, or complete logging.
- in Directory:
  Specify the directory where the TAPI log files should be stored.

Advanced parameters for TAPI

To configure advanced parameters for TAPI, select ‘View > Advanced’; or click the advanced button in the toolbar. You can now configure the following parameters:

Answer Timeout for Application:

In ‘Answer Timeout for Application’ specify the period of time, in milliseconds, within which the application must answer a call before the TSP offers the call to the next TAPI line. If one or more TAPI lines are found, the TSP signals an incoming call on the first line. If the call is answered by a TAPI application within the specified timeout, the call is assigned to this line. Otherwise, it is signaled to the next line.

Auto Alert Request:

Enable ‘Auto Alert Request’ to send an automatic ALERT_REQ as soon as a line is found that is potentially responsible for an incoming call.

Volume Outgoing

In ‘Volume Outgoing’ specify whether the volume of an outgoing call should be increased or reduced. The default value ‘32767’ leaves the volume unchanged. To increase the volume, enter a value higher than 32767. Note, however, that an increase in volume also increases the background noise of the call. To reduce the volume, enter a value lower than 32767.
The optimum volume value depends on your system. You might have to try out several values to optimize the sound quality.

**Eicon Wave driver**

When you install the Diva Server Telephony Service Provider and activate the modified configuration for your system, Diva Server for Windows 2000/XP automatically starts the installation of the Eicon Wave driver:

1. If a message appears indicating that the software has not been tested with Windows, continue the installation of the Eicon Wave driver.
2. In the ‘Configuration Update’ dialog box (which indicates that the configuration was updated successfully), click ‘OK’.
3. When prompted, restart your computer for the changes to take effect.

**Binding properties**

Bindings are used to connect the components of different layers. If you have installed several Diva Server adapters, the bindings for each adapter are distinguished by different colours.

**Note:** Components of the line layer cannot be connected directly to components of the services layer.

**Bindings between lines and Diva Server adapters**

**Connect to:**

This property is only available for bindings to Diva Server 4BRI adapters, because they can be connected to more than one line.

The ‘Connect to’ property indicates the line to which the Diva Server 4BRI adapter is connected. The lines are numbered in the sequence in which they are connected to the Diva Server 4BRI adapter, i.e. the first connected ISDN line is line 1, the second line 2, etc. You may change this sequence but make sure to assign each line number only once.
Bindings between Diva Server adapters and services

The configuration of these binding properties enables you to route incoming calls to a specific service. By default, the RAS and CAPI services are configured to accept all incoming calls. To avoid conflicts between these services, you should assign MSNs, ISDN numbers, or extensions to them. All other services, i.e. Modem, Modem Pool, and TAPI, are configured to accept no incoming calls. If you want these services to accept calls, you need to assign ISDN numbers or extensions to them.

When you are using a North American protocol with a BRI line, you must assign ISDN numbers, otherwise incoming calls cannot be accepted.

Note: If you assigned ISDN numbers to RAS in the ISDN wizard of Windows 2000 or Windows XP, RAS accepts incoming calls only for these numbers.

Number of B-Channels:

In ‘Number of B-Channels’, select the maximum number of B-channels to be made available for the service that is connected by the binding. The number of B-channels determines how many connections can be simultaneously established for the service. Depending on your line and your Diva Server adapter, up to 30 B-channels are available.

Note: The ‘Number of B-Channels’ parameter is not available for bindings to modems.

Controller:

For bindings to the CAPI service only: This parameter indicates which CAPI controller is used by the Diva Server adapter (see also CAPI properties on page 59).

Connect To:

This property is only available for bindings to Diva Server 4BRI adapters because they can be connected to more than one line.

Select here which ISDN line the service should use.

Call Type:

In ‘Call Type’, select which types of incoming calls should be routed to the service for the configured MSN, range of extensions, or ISDN number.

- All: All incoming calls for the given MSN, range of extensions, or ISDN number are routed to the service connected by the binding.
- Analog: Only incoming analog calls for the given MSN, range of extensions, or ISDN number are routed to the service connected by the binding.
- Digital: Only incoming digital calls for the given MSN, range of extensions, or ISDN number are routed to the service connected by the binding.
Call Answering:

Specify in ‘Call Answering’ which incoming calls the service connected to this binding should accept. The following options are available:

- **All Calls**: Select this option if you want the service connected to this binding to accept all incoming calls for the associated ISDN line, regardless of the dialed MSN, ISDN number, or extension. To avoid conflicts between the services, configure all other services to accept no calls for that line.

- **No Calls**: Select this option if you want the service connected to this binding to accept no incoming calls for the associated ISDN line.

  **Note**: The ‘No Calls’ option is not available for the RAS service. If you need to configure RAS to accept no calls for a certain ISDN line, remove the corresponding binding between the RAS service and the Diva Server adapter.

- **Specific Numbers**: Select this option if you want the service connected to this binding to accept calls to specific MSNs, ISDN numbers, or extensions for the associated ISDN line. Specify these phone numbers or extensions under ‘MSN’, ‘ISDN Number’, or ‘Lowest Extension’ and ‘Highest Extension’ (see below).

  **Note**: When activating a configuration, the configuration manager performs a plausibility check and generates a warning if several services are configured to accept the same incoming call.

**MSN:**

This parameter is only displayed if you have selected ‘MSN’ as number type in the ISDN line properties and set the ‘Call Answering’ parameter to ‘Specific Numbers’.

Specify the MSN(s) that should be routed to the service connected by the binding. The service will only accept incoming calls to these MSNs. You can select from the MSN(s) that you specified in the ISDN line properties (see also Number Type; on page 37).

You cannot assign the same MSN to several services (e.g. RAS, CAPI) if they are configured to accept calls of identical types (e.g. analog, digital).

**Lowest Extension / Highest Extension:**

These parameters are only displayed if you set the ‘Call Answering’ parameter to ‘Specific Numbers’ and use the ‘Range of Extensions’ number type (see also Number Type; on page 37).

Indicate the lowest extension that should be routed to the service in ‘Lowest Extension’ and the highest extension that should be routed to the service in ‘Highest Extension’. The service will only accept incoming calls to this range of extensions. Note that you can only define a range within the range of extensions that you configured in the ISDN line properties.
You cannot assign the same range of extensions to several services (e.g. RAS, CAPI) if they are configured to accept calls of identical types (e.g. analog, digital).

**ISDN Number 1 / ISDN Number 2:**

These parameters are only available if you are using a BRI line, have selected a North American switch type, and set the ‘Call Answering’ parameter to ‘Specific Numbers’.

Indicate the ISDN numbers that should be routed to the service connected by the binding. The service will only accept incoming calls to these ISDN numbers. You can select from the ISDN numbers that you specified in the ISDN line properties.

You cannot assign the same ISDN number to several services (e.g. RAS, CAPI) if they are configured to accept incoming calls of identical types (e.g. analog, digital).

**Specific properties of TAPI bindings**

**Number of TAPI Lines:**

In ‘Number of TAPI Lines’ specify the number of lines that should be made available to the TAPI service. This number determines how many connections can be simultaneously established for the TAPI service. Each active call occupies one TAPI line. The possible maximum of TAPI lines depends on the number of available B-channels.

**Phone Number Presentation:**

Specify in ‘Phone Number Presentation’ whether phone numbers should be presented or suppressed. If you want to use different settings for the called number and the calling number, select ‘User defined’. You can then see the following options:

- **CLIP - Calling Number Presentation:** If you want the complete calling party number to be presented to the destination party for outgoing calls, set ‘CLIP - Calling Number Presentation’ to ‘Yes’.
- **COLP - Called Number Presentation:** If you want the called party number to be presented to you, set ‘COLP - Called Number Presentation’ to ‘Yes’.

**Switch Profile:**

Some switches do not offer many service features. For these switches, the Diva Server adapter and software is able to simulate some of the missing features. Specify in ‘Switch Profile’ if simulation of features is necessary and which features must be simulated. The following ‘Switch Profile’ settings are available:

- **Simulate Missing Features:** If your switch does not provide explicit call transfer, overlap sending, three-party conference, and large conference, enable ‘Simulate Missing Features’ to have these features simulated and be able to use them.
• Necessary Features Are Supported: Select this option if your switch offers the required features and it is not necessary to simulate them with the Diva Server software.

• User defined: Select this option to specify which individual features are provided by your switch and which features need to be simulated:

  • Overlap Sending: Specify if your switch supports overlap sending. Overlap sending allows you to enter parts of the phone number after the audio channel to the switch has been established. You can hear the dial tone or announcements by the network provider etc.

  • ECT: Specify if your switch supports explicit call transfer.

  • 3pty Conference: Specify if your switch supports three-party conferences. Enter ‘0’ if it does not support three-party conferences and ‘3’ if it supports three-party conferences.

  • CONF: Specify if your switch supports large conferences. Enter the maximum number of participants.

  • Use Line Interconnect: Line interconnect enables you to connect two or more calls directly on the adapter. Thus, you can simulate ECT, three-party conferences, or large conferences even though your switch does not support these services. When you use line interconnect, each participant of a call occupies one B-channel. The TAPI line is able to service more than one active call which means that you can play music or announcements to one or all line interconnect participants or somebody can listen in on the call and talk to one or all participants.

  Example: A customer calls a call center and is connected to a fresh support person via line interconnect. A senior support person can listen in on the call and coach the fresh person without the customer noticing it.

  In ‘Use Line Interconnect’, enter the maximum number of participants.

  Note: If the value entered in ‘Use Line Interconnect’ is too small for a specific feature, for example the large conference, the feature is not available.

One MSN per TAPI Line:

Enable ‘One MSN per TAPI Line’ to assign one specific MSN to each TAPI line. If you are using a North American switch type with a BRI line, this parameter is enabled by default to ensure that each TAPI line uses its own SPID.
CHAPTER 6

Configuration Scenarios

This section describes three applications which you can implement with your Diva Server adapter and the Diva Server for Windows 2000/XP software.

Fax server

The fax server provides a bank of fax modems allowing users to fax out and remote users to fax in over the next available modem.

- The fax-server scenario uses multiple adapters, i.e., two Diva Server BRI-2M adapters, to create a fax application with one line reserved for RAS.
- Two BRI lines are used, one for each Diva Server BRI-2M adapter.
- The CAPI service is connected to both Diva Server BRI-2M adapters using one B-channel of the first adapter and two B-channels of the second adapter.
- A fax application is installed on top of CAPI. This means the three B-channels that are used by CAPI are available for fax services.
The BRI lines can be configured for 89 extensions, e.g. a range of extensions from 10 to 99.

A range of extensions is assigned to CAPI which allows direct dial-in on 88 extensions.

The RAS service is connected to one Diva Server BRI-2M adapter using one B-channel of that adapter. This channel is reserved for RAS and therefore RAS is possible even if all fax lines are busy.

RAS is only implemented for the system administrator and has therefore only one number of the range assigned.

**RAS server**

A RAS server enables remote users to access corporate LANs via analog modem or ISDN connections. It includes dial-up protocols and access control (authentication).

The RAS server scenario uses a Diva Server 4BRI-8M adapter to provide RAS to the users.

Four BRI lines are used for the Diva Server 4BRI-8M adapter.

The RAS uses all eight available B-channels of the Diva Server 4BRI-8M adapter. This means it has highest priority.

There is only one number assigned to the RAS because direct dial-in is not necessary.
The fax service is set up via a fax modem. The fax modem has no range of extensions or MSN assigned, therefore, only outgoing faxes are possible. Faxes can be sent only when one channel is not used by RAS because no B-channel is exclusively reserved for the fax services.

**CTI server**

The CTI server provides telephone and fax lines for services such as call centers.

- The CTI server scenario shows the use of a Diva Server PRI adapter for interactive voice response (IVR) and fax.
- One PRI line is used.
- The TAPI service is connected to the PRI adapter using 28 B-channels of the adapter because Interactive Voice Response that is installed on top of TAPI requires many channels.
- Direct dial-in is not necessary for Interactive Voice Response, therefore, only three extensions of the available range of extensions are assigned to the TAPI.
- CAPI is connected to the PRI adapter using the remaining two B-channels of the adapter that are reserved for the fax service (which is installed on top of CAPI).
- As for the fax service, direct dial-in is required and a range of 86 numbers is assigned to CAPI.
CHAPTER 7

Eicon Port Driver

Applications that are not TAPI-based need to address the Eicon Port driver, i.e. virtual COM port, directly. This means that you have to configure the COM port by using AT commands from within the applications.

Addressing the Eicon Port driver directly

1. Open the configuration manager: Click ‘Start > Programs > Diva Server for Windows 2000/XP > Diva Server Configuration Manager’.

2. Add a modem in the configuration manager: From the menu bar, select ‘Insert > Modem’.

3. In the properties pane, select any modem type under ‘Modem Name’. For further information on available modems, see Modem Name: on page 56.

4. If you need one COM port:
   Select in ‘Attached to COM Port’ the COM port on which the modem is to be installed. Write down the number so that you know which COM port you have to configure in your application.

   If you need more than one COM port:
   Convert the modem to a modem pool: Right-click the modem icon and select ‘Convert to Pool’. In the properties pane, specify in ‘First COM Port’ on which COM port the first modem of the pool is to be installed and enter in ‘Number of Modems’ the desired number of COM ports. Write down the numbers of the COM ports so that you know which COM ports you have to configure in your application.

5. Open your non-TAPI application and configure the COM port by using the AT commands listed below. For further information on using AT commands within your application, see the documentation of your application.

AT-command set of the Eicon Port driver

The Eicon Port driver supports the following AT-command set (parameters enclosed in square brackets are optional, variables are enclosed in angle brackets). These commands must be used from within your communications application.
### Standard AT commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A/</td>
<td>Repeats the previous command.</td>
</tr>
<tr>
<td>AT</td>
<td>No operation.</td>
</tr>
<tr>
<td>AT A</td>
<td>Answer - Has to be issued to accept an incoming call that has been indicated by a RING.</td>
</tr>
<tr>
<td>AT D &lt;Number&gt;</td>
<td>Dial - Dials the given number and switches to data mode after successful connection establishment.</td>
</tr>
<tr>
<td>AT D &lt;Number&gt;;</td>
<td>Dial - Dials the given number but remains in command mode when the connection has been established.</td>
</tr>
<tr>
<td>AT DP &lt;Number&gt;</td>
<td>Pulse Dialing - Dials according to the pulse code convention (is ignored with ISDN and treated as ATD).</td>
</tr>
<tr>
<td>AT DT &lt;Number&gt;</td>
<td>Tone Dialing - Dials according to the multiple frequency convention (is ignored with ISDN and treated as ATD).</td>
</tr>
</tbody>
</table>
| AT E [<n>] | Echo Mode - In echo mode, all commands sent to the modem are echoed back to the terminal.  
 n > 0: Echo Mode ON  
 n = 0: Echo Mode OFF |
| AT H [<n>] | Hangup - Disconnects the line.  
 0 < n < 3 is accepted for compatibility, but ignored by the driver. |
| AT I [<n>] | Info - Returns the modem identification string. |
| +++     | Escape - This escape sequence switches the modem back from the data mode to the command mode. |
| AT O [<n>] | Online - Switches the modem from the command mode to the data mode.  
 0 < n < 2 is accepted but ignored. |
| AT S <r> = <n> | Set S-Register - Stores the value <n> into the S-register <r>. The Eicon Port driver has only one register.  
 0: Auto answer  
 n = 0: Disables auto answer. Incoming calls are indicated by a RING.  
 0 < n < 255: Enables auto answer.  
 n = 255: Ignores all incoming calls. |
| AT S <r[=]> | Query S-Register - Queries the value of the S-register <r>. |
| AT Q [<n>] | Quiet - In quiet mode the modem driver does not return result codes for the commands.  
 n = 0: Returns result codes.  
 n > 0: Suppresses result codes. |
Verbal Mode - In verbal mode the modem driver returns result codes in plain text. Otherwise it returns numeric result codes.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
</table>
| AT V [<n>]| Verbal Mode - In verbal mode the modem driver returns result codes in plain text. Otherwise it returns numeric result codes.  
|           | n = 0: Numeric result codes  
<p>|           | n &gt; 0: Plain text result codes                                               |
| AT Z [&lt;n&gt;]| Soft Reset - Resets the modem and restores the predefined modem configuration profile &lt;n&gt;. See AT&amp;F[&lt;n&gt;] below for the list of predefined modem driver configurations. |
| AT &amp;C [&lt;n&gt;]| Ignored for compatibility.                                                  |
| AT &amp;D [&lt;n&gt;]| Ignored for compatibility.                                                  |</p>
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AT &amp;F [n]</strong></td>
<td>Factory Setting - Resets the modem and restores the predefined modem configuration profile (&lt;n&gt;).</td>
</tr>
<tr>
<td>n=1</td>
<td>X.75 (L1:HDLC framing, L2:X.75 SLIP, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP70</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=2</td>
<td>V.110 syncron (L1:V.110 syncron, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP2</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=3</td>
<td>V.110 asyncron (L1:V.110 asyncron, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP3</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=4</td>
<td>Analog syncron (L1:analog syncron, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP4</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=5</td>
<td>Analog asyncron (L1:analog asyncron, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP5</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=6</td>
<td>V.120 (L1:HDLC framing, L2:V.120, L3:TA)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP6</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=7</td>
<td>V.120 56K (L1:HDLC framing, L2:V.120, L3:TA)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP6</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=9</td>
<td>PPP (L1:HDLC framing, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM4</td>
<td>+iP9</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=10</td>
<td>PPP 56K (L1:HDLC framing, L2:transparent, L3:transparent)</td>
</tr>
<tr>
<td>+iM4</td>
<td>+iP9</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP7</td>
</tr>
<tr>
<td>(\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=14</td>
<td>Generic Server Modem (protocol will be detected)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP0</td>
</tr>
<tr>
<td>(\land) V0 (\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=15</td>
<td>X25 DTE Mode (L1:HDLC framing, L2:X.75 SLIP, L3:ISO 8208)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP12</td>
</tr>
<tr>
<td>(\land) V0 (\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>n=16</td>
<td>SDLC (L1:HDLC framing, L2:SDLC, L3:transparent)</td>
</tr>
<tr>
<td>+iM1</td>
<td>+iP13</td>
</tr>
<tr>
<td>(\land) V0 (\land) N3</td>
<td>%C3 · J1</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| AT &V [<n>]      | Displays the current configuration of the modem driver and the last number that has been dialed.  
|                  | n != 0: Also lists all predefined profiles.                                                                                               |
| AT +MS?          | Modulation Selection Query                                                                                                                |
|                  | The response to the query has the following form:                                                                                         |
|                  | AT +MS: <mod>,<auto>,<min>,<max>,<min_rx>,<max_rx>                                                                                         |
|                  | See 'Modulation Selection Set' below for explanations on the variables.                                                                     |
| AT +MS= [<mod>]  | Modulation Selection Set                                                                                                                  |
| [, [<auto>]      | Modulation Data Rate Range                                                                                                                |
| [, [<min>]       | mod = B103:* 300 bps                                                                                                                      |
| [, [<max>]       | mod = B212A: 1200 bps                                                                                                                     |
| [, [<min_rx>]    | mod = V21: 300 bps                                                                                                                        |
| [, [<max_rx>]]   | mod = V22: 1200 bps                                                                                                                      |
|                  | mod = V22B: 1200 - 2400 bps                                                                                                               |
|                  | mod = V23C:* Tx:75 bps/Rx:1200 bps Outgoing call                                                                                           |
|                  | Tx:1200 bps/Rx:75 bps Incoming call                                                                                                       |
|                  | mod = V32: 4800 - 9600 bps                                                                                                                |
|                  | mod = V32B: 4800 - 14400 bps                                                                                                              |
|                  | mod = V34: 2400 - 33600 bps                                                                                                               |
|                  | mod = V90: 28000 - 56000 bps send (server -> client)                                                                                      |
|                  | 2400 - 33600 bps receive (server <- client)                                                                                              |
|                  | mod = V90A:* 2400 - 33600 bps send (server -> client)                                                                                     |
|                  | 28000 - 56000 bps receive (server <- client)                                                                                              |
|                  | Try other modulations if specified modulation cannot be used.                                                                           |
|                  | auto = 0: Use only the specified modulation.                                                                                              |
|                  | auto = 1: Try other modulations with lower data rate.                                                                                     |
|                  | min = Minimum (transmit) data rate.                                                                                                       |
|                  | max = Maximum (transmit) data rate.                                                                                                       |
|                  | min_rx = Minimum (receive) data rate.                                                                                                     |
|                  | max_rx = Maximum (receive) data rate.                                                                                                     |
|                  | Only V90 modulation has a different transmit/receive rate. Rate = 0 means no minimum or maximum limitation.                              |
|                  | Valid Rate Values (in bps):                                                                                                              |
|                  | 75, 300, 600, 1200, 2400, 4800, 7200, 9600, 12000, 14400, 16800, 19200, 21600, 24000, 26400, 28000, 28800, 29333, 30667, 31200, 32000, 33600, 33400, 34667, 36000, 37333, 38000, 38667, 40000, 41333, 42000, 42667, 44000, 45333, 46000, 46667, 48000, 49333, 50000, 50667, 52000, 53333, 54000, 54667, 56000, 0 |
|                  | *Modulations are not available with Diva Server BRI-2M (rev.1) adapters.                                                                |
| AT \T [<n>]      | Inactivity Timeout - The modem driver releases the connection if there was no data traffic for <n> times 10 seconds.                          |
|                  | n = 0: Disables inactivity timeout.                                                                                                       |
|                  | n > 0: Disconnects after <n> * 10 seconds idle time.                                                                                    |
**Command** | **Description**
--- | ---
AT \D [n>] | Debug Level - Specifies the kind of events that should be reported by the driver. You can view the messages with the help of the Diva Server Diagnostics application. <n> is interpreted as a bit mask as follows:
- Bit 0: Error messages
- Bit 1: Connection related events
- Bit 2: PPP control protocol frames
- Bit 3: Read / write requests directed to the port driver
- Bit 4: Function calls
- Bit 5: Notifications sent by the port driver
- Bit 6: Full B-channel data trace
- Bit 7: Parameters
Set the related bit to '1' for every kind of message you want to see in the log.
Default: n = 3 (Errors and connection events)

AT \V<n> | Indication of connection parameters in CONNECT response.
- n = 0 Connection parameters are not indicated.
- n = 1 Connection parameters are indicated.

The connection parameters are displayed in the following format:
CONNECT <modulation>/<options>/<txspeed>:TX/<rxspeed>:RX
- modulation: V21, V22, V23, V32, V34, V90 etc. (see AT +MS command)
- options: LAPM/V42BIS, LAPM, MNP5, MNP
- txspeed: 300, 1200, 2400, ..., 33600 etc. (transmit rate)
- rxspeed: 300, 1200, 2400, ..., 33600 etc. (receive rate)

AT #CID=<n> | The port driver indicates the origination and destination number in the RING and/or CONNECT response. This enables a server application for example to forward incoming faxes directly to their destination.

The information appended to the CONNECT or RING response can have two formats:
- Format 1: CID: xxx,
  where xxx = calling party number
- Format 2: CID: xxx DAD: yyy,
  where xxx = calling party number and yyy = called party number
- n = 0 Turn CID off
- n = 1 Turn CID on, RING with format 1
- n = 2 Turn CID on, CONNECT with format 1
- n = 3 Turn CID on, RING and CONNECT with format 1
- n = 5 Turn CID on, RING with format 2
- n = 6 Turn CID on, CONNECT with format 2
- n = 7 Turn CID on, RING and CONNECT with format 2
- n = ? Returns the current mode
Supported AT commands for fax (excerpt of complete list)

The port driver functions as a Fax Class 1 and Class 2 modem and it supports all standardized AT +F commands. However, only the AT +F commands that can reasonably be used manually are described below.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AT +FCLASS?</td>
<td>Queries the configured modem class.</td>
</tr>
<tr>
<td></td>
<td>0 = Data Mode</td>
</tr>
<tr>
<td></td>
<td>1 = EIA Class 1</td>
</tr>
<tr>
<td></td>
<td>1.0 = EIA Class 1.0 (V.34 Fax)</td>
</tr>
<tr>
<td></td>
<td>2 = EIA Class 2</td>
</tr>
<tr>
<td>AT +FCLASS=?</td>
<td>Displays all supported modem classes.</td>
</tr>
<tr>
<td>AT +FCLASS=&lt;n&gt;</td>
<td>Configures the modem for modem class &lt;n&gt;.</td>
</tr>
<tr>
<td>AT +FMFR?</td>
<td>Returns the name of the modem manufacturer.</td>
</tr>
<tr>
<td>AT +FMDL?</td>
<td>Returns the name of the modem model.</td>
</tr>
<tr>
<td>AT +FREV?</td>
<td>Returns the product version.</td>
</tr>
</tbody>
</table>
### ISDN-specific AT commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AT +iM &lt;n&gt;</strong></td>
<td>Working Mode - Sets the working mode of the modem.</td>
</tr>
<tr>
<td>n = 0:</td>
<td>Undefined</td>
</tr>
<tr>
<td>n = 1:</td>
<td>Data Modem</td>
</tr>
<tr>
<td>n = 2:</td>
<td>Fax Modem</td>
</tr>
<tr>
<td>n = 3:</td>
<td>Voice Modem</td>
</tr>
<tr>
<td>n = 4:</td>
<td>RNA Modem (Enables frame conversion for RNA networking.)</td>
</tr>
<tr>
<td>n = 5:</td>
<td>BTX Modem (Enables frame conversion for modem based BTX decoders.)</td>
</tr>
<tr>
<td>n = 6:</td>
<td>Frame Mode (Keeps frame boundaries of the ISDN data frames.)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>AT +iP &lt;n&gt;</strong></th>
<th>B-channel Protocol</th>
</tr>
</thead>
<tbody>
<tr>
<td>n = 0:</td>
<td>Undefined</td>
</tr>
<tr>
<td>n = 1:</td>
<td>X.75</td>
</tr>
<tr>
<td>n = 2:</td>
<td>V.110 synchronous</td>
</tr>
<tr>
<td>n = 3:</td>
<td>V.110 asynchronous</td>
</tr>
<tr>
<td>n = 4:</td>
<td>Analog Modem synchronous</td>
</tr>
<tr>
<td>n = 5:</td>
<td>Analog Modem asynchronous</td>
</tr>
<tr>
<td>n = 6:</td>
<td>V.120</td>
</tr>
<tr>
<td>n = 7:</td>
<td>T.30 (Fax)</td>
</tr>
<tr>
<td>n = 9:</td>
<td>HDLC Framing (for PPP connections over ISDN)</td>
</tr>
<tr>
<td>n = 10:</td>
<td>T.70 (BTX)</td>
</tr>
<tr>
<td>n = 12,&lt;m&gt;,&lt;w&gt;,&lt;l&gt;,&lt;h&gt;:</td>
<td>X.25 with protocol parameters for ISO8208</td>
</tr>
<tr>
<td>m: modulo:</td>
<td></td>
</tr>
<tr>
<td>m = 8:</td>
<td>sequence numbers of data packets are 0 to 7.</td>
</tr>
<tr>
<td>m = 128:</td>
<td>sequence numbers of data packets are 0 to 127.</td>
</tr>
<tr>
<td>w: window size:</td>
<td>specifies how many packets can be sent before an ACKNOWLEDGE must be received.</td>
</tr>
<tr>
<td>w = 1-8, if modulo is 8</td>
<td></td>
</tr>
<tr>
<td>w = 1-128, if modulo is 128</td>
<td></td>
</tr>
<tr>
<td>l: lowest two-way channel:</td>
<td>the number of the lowest usable channel</td>
</tr>
<tr>
<td>l = 1-4095</td>
<td></td>
</tr>
<tr>
<td>h: highest two-way channel:</td>
<td>the number of the highest usable channel</td>
</tr>
<tr>
<td>h = 1-4095; must be higher than lowest channel</td>
<td></td>
</tr>
<tr>
<td>n =13:</td>
<td>SDLC</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>AT +iS &lt;x&gt;/&lt;y&gt;</td>
<td>Service Indicator/Additional Service Indicator&lt;br&gt;It tells the remote site which kind of connection you want to establish.&lt;br&gt;Command affects the Low-Layer Capabilities (LLC) element on the SETUP message.&lt;br&gt;x: Service Indicator&lt;br&gt;y: Additional Service Indicator&lt;br&gt;x/y = 1/1 ISDN Voice call 3.1 kHz&lt;br&gt;x/y = 1/2 Analog Voice call&lt;br&gt;x/y = 1/3 ISDN Voice call 7 kHz&lt;br&gt;x/y = 2/1 Fax Group 2&lt;br&gt;x/y = 2/2 Fax Group 3&lt;br&gt;x/y = 2/3 Data over modem connection&lt;br&gt;x/y = 2/4 BTX over modem connection&lt;br&gt;x/y = 7/0 64 kbps Data&lt;br&gt;x/y = 7/170 56 kbps Data&lt;br&gt;x/y = 7/197 V.110 Rate Adaptation</td>
</tr>
<tr>
<td>AT +iN &lt;x&gt;/&lt;y&gt;</td>
<td>Numbering Plane Identifier&lt;br&gt;x: Identification for the local phone number&lt;br&gt;y: Identification for the remote phone number&lt;br&gt;Note: The modem driver applies default numbering plane identifiers that need not be changed.</td>
</tr>
<tr>
<td>AT +iO &lt;Number&gt;</td>
<td>Origination Address - The modem driver places this number as the origination address.</td>
</tr>
<tr>
<td>AT +iA &lt;Number&gt;</td>
<td>Accepted Address - The modem driver only accepts incoming calls if the called party number equals the phone number configured here.</td>
</tr>
</tbody>
</table>
**Command** | **Description**  
--- | ---  
**AT +iF <n>** | RNA-Framing (applies only to the RNA mode)  
  n = 0: No Framing check  
  n = 1: Force synchronous conversation  
  n = 2: Force asynchronous conversation  
  n = 3: Detect necessary conversation by analyzing incoming data packets.  
**AT +iB <n>** | B-channel Data Rate for digital protocols  
  n = 0: Not Supported  
  n = 1: 600 bps  
  n = 2: 1200 bps  
  n = 3: 2400 bps  
  n = 4: 4800 bps  
  n = 5: 9600 bps  
  n = 6: 19200 bps  
  n = 7: 38400 bps  
  n = 8: 48000 bps  
  n = 9: 56000 bps  
  n = 10: 64000 bps  
  n = 11: 7200 bps  
  n = 12: 12000 bps  
  n = 13: 14400 bps  
  n = 14: 28800 bps  
  n = 255: Default (V.110: 38400 bps; others: 64000 bps)  
**Note:** The supplied data transfer rates depend on the selected protocol:  
V.110 syncron: 600 bps - 48000 bps  
V.110 asynchron: 600 bps - 56000 bps  
others: 56000 bps and 64000 bps  
Some telephone switches in the USA only support 56000 bps. If there are any connection problems with 64000 bps, you can reduce the data transfer rate of the X.75, V.120, PPP and other digital protocols to 56000 bps. But this has to be done on both sides of the connection (the calling side as well as the called side).
CHAPTER 8

Dial-Up Networking and RAS Administration

In the terminology used by the Remote Access Service, the calling station is referred to as the **Client** and the called station as the **Server**. The RAS client/server architecture allows a station to be defined simultaneously as a server and as a client and therefore enables simultaneous initiation of outgoing and incoming ISDN connections. For example, this enables the peer-to-peer connection of two Windows 2000 or Windows XP workstations.

**RAS client setup**

The RAS client can be used to establish connections to the following remote stations:

- Windows 2000 or Windows XP computer with RAS in server mode
- Internet Service Provider
- TCP/IP router

How to set up the RAS client depends on your operating system:

- If you are setting up your RAS client under Windows 2000, see [Setting up a RAS client under Windows 2000](#) below.
- If you are setting up a RAS client under Windows XP, see the section [Setting up a RAS client under Windows XP](#) on page 85.

**Setting up a RAS client under Windows 2000**

1. Click ‘Start > Settings > Network and Dial-up Connections’.
2. In the ‘Network and Dial-up Connections’ dialog box, double-click ‘Make New Connection’.
3. If the ‘Location Information’ dialog box appears, enter the country/region you are in. Enter your area code and, if required, your number to access an outside line. Click ‘OK’.
4. If the ‘Phone and Modem Options’ dialog box appears, select your location. Click ‘OK’.
5. In the ‘Network Connection Wizard’, click ‘Next’.
6. In the ‘Network Connection Type’ dialog box, select ‘Dial-up to private network’.

![Network Connection Type dialog box]

Click ‘Next’.

7. If you have configured more than one port for outgoing calls, you must specify a port:

![Select a Device dialog box]

Select a port, e.g. ‘ISDN channel - Eicon Diva Server BRI-2M (PCI)’ to dedicate a line to this outgoing connection.

The effect of the setting ‘All available ISDN lines multi-linked’ is that RAS will automatically establish a connection over all lines.

**Note:** Note that a larger number of active lines may increase telephone charges. With a normal basic rate interface, a connection with the setting ‘All available ISDN lines multi-linked’ would be established over both B-channels.

Click ‘Next’.
8. In the ‘Phone Number to Dial’ dialog box, enter the phone number of the server:

<table>
<thead>
<tr>
<th>Designation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>^HDLC</td>
<td>synchronous HDLC</td>
</tr>
<tr>
<td>^X.75</td>
<td>synchronous X.75</td>
</tr>
</tbody>
</table>

If the server is configured to use subaddresses, you must specify the appropriate subaddresses in the ‘Phone Number to Dial’ dialog box, separated by the vertical stroke ‘|’ (the pipe symbol, or press [Alt] and the digits [0], [1], [2] and [4] on the numeric keypad).

For example, if the phone number is 07152932640 SUB 41, you must enter 07152932640|41.

If your connection protocol is something other than synchronous HDLC, you must specify which protocol is used. This information can be attached to the server phone number, separated by a ‘^’.

For example, for an analog call, add ‘^MODEM’ to the phone number of the server. For a call to GSM, add ‘^GSM1’, ‘^GSM2’ or ‘^GSM3’.

If your connection uses something other than a transfer rate of 64 kbps, you must specify which transfer rate is used. This information can also be attached to the server phone number separated by a ‘^’.

For example, for a call to some regions in the United States where a line, a switch, or a device only supports a transfer rate of 56 kbps, add ‘^56K’ to the server phone number. The ‘T1 RBS’ switch type always uses a transfer rate of 56 kbps. Therefore, you must add ‘^56K’ for all outgoing calls if you use this switch type.

The required information can be found in the following table. The various parameters can also be entered in combination.
Click ‘Next’.

9. In the ‘Connection Availability’ dialog box, select if the connection should be made available to all users or only to yourself.

Click ‘Next’.
10. If you are connected to a network and you selected to make the connection available to all users, the ‘Internet Connection Sharing’ dialog box is displayed. Specify if your Internet connection can be shared by all users or if it should be available only to yourself. Click ‘Next’.

11. In the ‘Completing the Network Connection Wizard’ enter a name for your RAS connection. Click ‘Finish’ to save the newly set-up RAS client. If you need to make changes, click ‘Back’ until you reach the dialog box where the changes are to be made.

12. In the displayed dialog box, click the ‘Dial’ button to connect.

Setting up a RAS client under Windows XP


2. In the ‘Network Connections’ window, under ‘Network Tasks’ on the left window side, double-click ‘Create a new connection’.

3. If the ‘Location Information’ dialog box appears, enter the country/region you are in. Enter your area code and, if required, your number to access an outside line. Click ‘OK’.

4. If the ‘Phone and Modem Options’ dialog box appears, select your location. Click ‘OK’.

5. In the ‘New Connection Wizard’, click ‘Next’.

6. In the ‘Network Connection Type’ dialog box, select ‘Connect to the network at my workplace’.

7. In the ‘Network Connection’ dialog box, select ‘Dial-up connection’ and click ‘Next’.
8. If you have configured more than one port for outgoing calls, you must specify a port:

Select a port, e.g. ‘ISDN channel - Eicon Diva Server BRI-2M (PCI) ’ to dedicate a line to this outgoing connection.

The effect of the setting ‘All available ISDN lines multi-linked’ is that RAS will automatically establish a connection over all lines.

**Note:** Note that a larger number of active lines may increase telephone charges. With a normal basic rate interface, a connection with the setting ‘All available ISDN lines multi-linked’ would be established over both B-channels.

Click ‘Next’.

9. In the ‘Connection Name’ dialog box, enter a name for your RAS connection. Click ‘Next’.

10. In the ‘Phone Number to Dial’ dialog box, enter the phone number of the server:

   If the server is configured to use subaddresses, you must specify the appropriate subaddresses, separated by the vertical stroke ‘|’ (the pipe symbol, or press [Alt] and the digits [0], [1], [2] and [4] on the numeric keypad).

   For example, if the phone number is 07152932640 SUB 41, you must enter 07152932640|41.

   If your connection protocol is something other than synchronous HDLC, you must specify which protocol is used. This information can be attached to the server phone number, separated by a ‘^’.

   For example, for an analog call, add ‘^MODEM’ to the phone number of the server. For a call to GSM, add ‘^GSM1’, ‘^GSM2’ or ‘^GSM3’.

   If your connection uses something other than a transfer rate of 64 kbps, you must specify which transfer rate is used. This information can also be attached to the server phone number separated by a ‘^’.
For example, for a call to some regions in the United States where a line, a switch, or a device only supports a transfer rate of 56 kbps, add ‘^56K’ to the server phone number. The ‘T1 RBS’ switch type always uses a transfer rate of 56 kbps. Therefore, you must add ‘^56K’ for all outgoing calls if you use this switch type.

For detailed information on how to specify the required connection protocol or speed, see the table on page 83.

Click ‘Next’.

11. In the displayed dialog box, click ‘Finish’ to save the newly set-up RAS client. If you need to make changes, click ‘Back’ until you reach the dialog box where the changes are to be made.

12. In the displayed dialog box, click the ‘Dial’ button to connect.

**Assign multiple phone numbers to a connection**

You can assign several phone numbers to a connection. These phone numbers will be used as alternative numbers if the first number fails for example, when the line is busy.

1. **Under Windows 2000:**
   Click ‘Start > Settings > Network and Dial-up Connections’ and right-click the connection to which you want to assign multiple numbers.

   **Under Windows XP:**
   Click ‘Start > Settings > Control Panel’. Double-click ‘Network Connections’ and right-click the connection to which you want to assign multiple numbers.

2. Select ‘Properties’.

3. In the properties dialog box of your connection, click the ‘General’ tab. Click ‘Alternates’.

4. In the ‘Alternate Phone Numbers’ dialog box, check the option ‘If number fails, try next number’.

5. To add a new phone number to the list, click ‘Add’.

6. In the ‘Add Alternate Phone Number’ dialog box, type the phone number. Click ‘OK’.

7. Click ‘OK’ to close the ‘Alternate Phone Numbers’ dialog box.

8. Click ‘OK’ again to close the properties dialog box.

To observe the progress of an active connection, click ‘Start > Settings > Network and Dial-up connections’ and right-click the connection. Select ‘Status’ (see also RAS status on page 91).

To specify the network protocol(s) for every set-up connection, click ‘Start > Settings > Network and Dial-up connections’ and right-click the connection. Select ‘Properties’.
In the properties dialog box of your connection, click the ‘Networking’ tab. You can now activate the desired network protocol(s) for your connection.

For more detailed information on the RAS client, see the Windows 2000 or Windows XP RAS documentation.

**RAS server setup**

**Note:** Windows XP Professional allows you to set up an incoming connection that can accept up to three incoming calls. To do so, start the ‘New Connection Wizard’ and select ‘Set up an advanced connection > Accept incoming connections’. Since Windows XP Professional does not allow to set up a RAS server for a large number of incoming connections, the following description only refers to the Windows 2000 Server operating system.

The Remote Access application enables you to configure and control the RAS server.

Your computer is automatically launched as server when Windows 2000 Server starts but you still need to configure and enable remote access.

**To configure and enable remote access:**

1. Click ‘Start > Programs > Administrative Tools > Routing and Remote Access’.
2. In the ‘Routing and Remote Access’ window, right-click the entry for your computer and select ‘Configure and Enable Routing and Remote Access’.
4. In the displayed dialog box, select ‘Remote access server’.

   ![Common Configurations]

   ![Next]

   ![Cancel]

Click ‘Next’.
5. In the ‘Remote Access Server Setup’ dialog box, select the option ‘Set up an advanced remote access server’.
   Click ‘Next’.

6. In the ‘Remote Client Protocols’ dialog box, verify if all protocols required for remote clients are installed.
   Click ‘Next’.

7. If you are not connected to a network, the ‘No Network Connections Detected’ dialog box is displayed.
   Check the option ‘No, I am setting up a standalone server with no access to a network’.
   Click ‘Next’.

8. In the ‘IP Address Assignment’ dialog box, specify whether IP-addresses will be assigned to remote clients automatically or from a specified range.
   Click ‘Next’.
   **Note:** If you select to assign the IP-addresses from a specified range, enter the address ranges in the following dialog boxes.

9. If your computer is part of a network, the ‘Managing Multiple Remote Access Servers’ dialog box is displayed.
   Specify if you want to set up your RAS server to use an existing RADIUS server. By default, the RADIUS server is not used.
   The RADIUS (Remote Authentication Dial-In User Service) protocol is used for managing remote user authentication and authorization in dial-up networks or virtual private networks. If a RADIUS server is available in your LAN you can have your RAS connections authenticated and monitored by this server. You do not need to create your own remote access policies.
   Click ‘Next’.


**To configure access authorizations for the RAS server:**

1. Click ‘Start > Programs > Administrative Tools > Computer Management’.

2. In the ‘Computer Management’ window, select ‘System Tools > Local Users and Groups > Users’.

3. In the details pane, right-click the user for whom you want to configure the access authorizations.
   Select ‘Properties’.
4. In the properties dialog box, select the ‘Dial-in’ tab and activate the desired access rights:

- **Allow access**
  The user has the direct permission to dial into the RAS server. This permission overrules all remote access policies.

- **Deny access**
  The user has no permission to dial into the RAS server. This denial also overrules all remote access policies.

- **Control access through Remote Access Policy**
  Depending on the Remote Access Policy, dial-in permission is granted or denied to the user. For further information on Remote Access Policies, see your Windows 2000 documentation.

The following callback options can be configured:

- **No Callback**
  The client establishes the connection to the server and maintains the connection. The user of the RAS client assumes all charges.

- **Set by Caller (Routing and Remote Access Service only)**
  The client establishes the connection to the server, sends its current call number and then breaks the connection. The server calls the client back at the number given and therefore assumes the charges for the call. The client's call can therefore be made from any site.
Always Callback to
The client establishes the connection to the server, thereby indicating that a connection is required, and then breaks the connection. The server calls the client back at the preassigned call number. This ensures that the client can call from one telephone terminal only. This ensures that no other partner can call from another terminal, because this call number cannot be manipulated.

Close the dialog box by clicking ‘OK’.

Note: Only the users that are set up on the server are shown in the ‘Users’ list. For information on how to configure authorizations for remote access for Windows 2000 domains, see your Windows 2000 documentation.

RAS status

To monitor a currently active connection:

1. To monitor the status of a currently active outgoing connection, right-click the connection. Select ‘Status’.
2. The ‘RAS Status’ monitor is displayed:

   ![RAS Status Monitor](image)

To monitor a connection each time it is active:

1. Click ‘Start > Settings > Network and Dial-up Connections’. Select the desired connection.
2. In the displayed dialog box, click ‘Properties’. 
3. In the properties dialog box, click the ‘General’ tab:

![RAS Client dialog box]

Check the option ‘Show icon in taskbar when connected’. Click ‘OK’.

4. Each time, when the connection is active, an icon is displayed in the Windows taskbar.

**To monitor the status of RAS server ports:**

1. To monitor the status of a RAS server port, click ‘Start > Programs > Administrative Tools > Routing and Remote Access’.
2. In the ‘Routing and Remote Access’ window, click the ‘+’ next to your RAS server to expand the tree.
3. Click ‘Ports’ to display the available ports in the right window pane.
4. Double-click the port for which you want to display the ‘Port Status’.
CHAPTER 9

Changing Your Installation

Adding Diva Server adapters

1. After you have installed your new Diva Server adapter as described in the printed manual that came with your adapter, start your computer.
2. Windows 2000 or Windows XP detects the Diva Server adapter.
3. In the ‘ISDN Switch Type or D-channel Protocol’ dialog box, indicate the required D-channel protocol (see page 14).
4. In the displayed dialog box, you may enter the MSNs or SPIDs and phone numbers for RAS as required (see page 15).
5. If the ‘Found New Hardware’ wizard is displayed, click ‘Finish’.
6. If prompted, restart your computer
7. Open the configuration manager: click ‘Start > Programs > Diva Server for Windows 2000/XP > Diva Server Configuration Manager’.
8. The configuration manager displays the basic configuration of the new Diva Server adapter: ISDN line, adapter, RAS, and CAPI.
9. You can now configure your new Diva Server adapter as described in the chapter Configuration Manager on page 30.

Uninstalling

If you need to uninstall your Eicon Diva Server adapter, follow the instructions below:

2. In the ‘System Properties’ dialog box, click the ‘Hardware’ tab.
   Click ‘Device Manager’.
3. In the ‘Device Manager’ dialog box, right-click the entry of the Diva Server adapter that you want to uninstall.
4. Click ‘Uninstall’.
5. In the ‘Confirm Device Removal’ dialog box, click ‘OK’ to start the uninstallation.
6. Shut-down your computer and physically remove the Diva Server adapter from your system. Otherwise, Windows 2000 or Windows XP will detect and install the adapter again as soon as you restart your computer.
CHAPTER 10

Shorthold

During data exchange between computers, there are always idle periods. If the connection continues during these periods, unnecessary charges will be incurred.

The shorthold mode reduces these charges. It breaks the physical connection during periods where no transmission takes place and only reconnects to the remote station when data has to be transmitted. Therefore, the physical connection over the ISDN is established only during actual data transmission. The shorthold is not displayed in the data transmission monitor.

The Diva Server for Windows 2000/XP shorthold is an Eicon WAN-Miniport option and therefore only functions between two computers equipped with Eicon ISDN adapters.

Note: The shorthold mode can only be used efficiently with straight TCP/IP connections. Other protocols send regular broadcasts, with the result that there are no periods that are really transmission-free. The autonomous data compression in the Windows 2000 or Windows XP RAS does not provide a mechanism for filtering out these broadcasts.

When using shorthold, make sure to deactivate the autodisconnect in the RAS. For information on how to deactivate the autodisconnect, see your Windows 2000 or Windows XP documentation.

Breaking and re-establishing connections

Shorthold is activated and configured during configuration of RAS in the configuration manager (see Shorthold Mode: on page 52).

To enable shorthold mode, the option ‘Shorthold Mode’ must be enabled on both sides. The value in seconds after which a shorthold should be initiated must be entered for ‘Shorthold Time (sec)’.

Only one side can initiate and re-establish a shorthold at any time. The other side should set a ‘0’ as ‘Shorthold Time (sec)’.

Once the specified shorthold time has expired, the side that controls the shorthold breaks the connection. When it needs to send new data, it will re-establish the connection.

However, if the other side wishes to be the first to send a data packet, it will have to ‘notify’ the side that initiated the shorthold. That means that it calls without establishing a connection. The side controlling the shorthold will then call back and establish the connection.
Exclusive allocation of charges

When the Diva Server for Windows 2000/XP shorthold is appropriately configured, charges are allocated exclusively either to the calling computer (see Charged to the RAS client, below) or to the called computer (see Charged to the RAS server on page 97).

Note: In countries where a dial attempt is subject to a charge even when a connection is not established (e.g. Switzerland), charge allocation does not function exclusively. In this case the side that notifies the other after a shorthold and therefore requests the establishment of a connection will pay the charges for the notification.

Charged to the RAS client

The RAS client establishes the connection, initiates the shorthold and reconnects the subsequent calls. In this way, the charges are allocated to the RAS client only.

Client configuration (see Shorthold Mode: on page 52):
- Shorthold Mode = Yes
- Shorthold Time must be set to a value not equal to zero. It should be set to the charge period or a multiple to enable the most efficient possible usage of already paid charge periods.

Server configuration (see Shorthold Mode: on page 52):
- Shorthold Mode = Yes
- Shorthold Time = 0
- No different MSNs or extensions should be assigned to the RAS ports. This will ensure that not just one server port will be available for the initial establishment of a connection on the client side.
Charged to the RAS server

The RAS client calls the RAS server and requests a callback. The RAS server establishes the connection using the callback function of the RAS, initiates the shorthold and reconnects the subsequent calls.

For example, in the case of remote workstations, users can call the company server and have the RAS server call back. This ensures that the server bears all charges for the call.

Client configuration (see Shorthold Mode: on page 52):

- Shorthold Mode = Yes
- Shorthold Time = 0

Server configuration (see Shorthold Mode: on page 52):

- The RAS callback mode must be activated (see To configure access authorizations for the RAS server: on page 89).
- No different MSNs or extensions should be assigned to the RAS ports. This ensures that not just one server port is available on the first call or for the client's ‘notification’.
- Shorthold Mode = Yes
- Shorthold Time must be set to a value not equal to zero. It should be set to the charge period or a multiple to enable the most efficient possible usage of already paid charge periods.

Note: The number checking file may be used for access control to prevent the charges accepted by the server from uncontrolled use. See Number Checking: on page 53.
Shorthold and Multilink PPP

If the shorthold mode is to be used with Multilink PPP, the RAS ports on the RAS client must definitely be assigned different MSNs. The RAS server requires the MSNs so that it can re-establish the connection correctly after a shorthold.

**Note:** If the RAS client needs to use the callback, it cannot work with Multilink PPP. However, if Multilink PPP is required, for example to transfer larger files more quickly, the callback must be deactivated and the RAS client must carry the charges.

Callback numbers

Regardless of whether the RAS client or the RAS server carries the charges, the server requires the client's correct callback number.

**Note:** If the exchange does not send the client's call number, the WAN-Miniport driver will reject the RAS server's shorthold requests. In this case, it will have no information on what number it should dial for a callback.

If the RAS client numbers provided by the exchange cannot be called back, for example because the leading zero for the area code (Euro-ISDN) or the number required for external calls with PBX systems is not provided, there are two options:

- Call number check (see [Number Checking](#) on page 53):
  The correct callback number is preconfigured for every RAS client.

- Callback prefix (see [Callback Prefix](#) on page 51):
  One or more digits are placed before the callback numbers of all RAS clients (e.g. for an external call).

Callback numbers with callback

If the server is being operated in callback mode, the call number or the callback prefix is not checked when establishing the connection after a shorthold. The WAN-Miniport driver records all PPP callback queries and the negotiated callback period internally and compares them with the incoming and outgoing calls. Because the server has already dialed the right number on callback, it makes no difference if the exchange has provided an incomplete number. If all calls are made with unique identifiable MSN/EAZs, the WAN-Miniport driver will recall the right number.

Determining correct callback numbers

The call number provided by the exchange and the actual number called can be displayed as follows:

Set up a trace file with the Diva Server Diagnostics (see [Diva Server Diagnostics](#) on page 108). The number can be read at the entries ‘Called by xxx’ or ‘Dialing xxx.’
CHAPTER 11

Security Dynamics Authentication

Diva Server for Windows 2000/XP supports Security Dynamics authentication as an additional security feature against unauthorized access to your Windows 2000 or Windows XP server. If there is a Security Dynamics ACE/Server (ACE = Access Control & Encryption) on the network and all authorized clients have the corresponding SecurID tokens, access to the Windows 2000 or Windows XP server via ISDN can also be made secure with Security Dynamics authentication.

The Security Dynamics System functions as follows:

On the server side there is the ACE/Server and on the client side the SecurID tokens. Every client requires an individual SecurID token to generate its own time-dependent PASSCODEs. The SecurID token generates a six-digit number code in accordance with an individual algorithm adjusted to the server, which changes every 60 seconds. The token code together with the personal PIN, that is assigned to every client, yield the PASSCODE. See the figure of a standard SecurID token below:

The Security Dynamics authentication is a special server feature independent of the client side. The only requirement for the client is that it must be able to implement PPP connections over the ISDN and enter a user name with password.

Security Dynamics authentication can be done via modem emulation.

Security Dynamics authentication via modem emulation

The Remote Access Security Solution from Security Dynamics is designed to work with external modems. If you have the Eicon Diva Generic Server Modem installed, Remote Access Security can be supported without any restrictions.
The server side

The Security Dynamics ACE/Server can be installed on the Windows 2000 or Windows XP server directly. It is not necessary to add additional protocols like RADIUS or TACACS+. The Security Dynamics ACE/Agent should also be installed on the server. The ACE/Agent controls the Dial-Up Networking connection. See in the illustration below how the Security Dynamics authentication functions:

For information on the installation and configuration of the ACE/Server and ACE/Agent see your Security Dynamics documentation.

The client side

On the client side, the Dial-Up Networking connection must also work with an asynchronous device such as:

- external or internal analog modem
- external ISDN modem
- ISDN modem emulation

The client must be configured with a pop-up terminal window after the connection is made.

To configure the client with a pop-up terminal window:

1. Click ‘Start > Settings > Network and Dial-up Connections’.
2. Right-click the connection for which Security Dynamics authentication is required and select ‘Properties’.
3. In the connection’s properties dialog box, select the ‘Security’ tab.
4. In ‘Interactive logon and scripting’, check the option ‘Show terminal window’.
   Click ‘OK’.
5. After dialing into the server, the ‘After Dial Terminal’ window pops up.

This terminal window is used for the Security Dynamics authentication and for some additional conversation to the server, such as ‘Next Tokencode’ and ‘Next PIN’ mode.

Enter your username, domain and passcode. To continue, click ‘Done’.
CHAPTER 12

Management Tools

Diva Server Monitor

The Diva Server Monitor is automatically installed with your Diva Server for Windows 2000/XP software. It displays the status of all B-channels and thus provides information on the currently active connections of your system. In addition, the Diva Server Monitor records all incoming and outgoing connections of your computer so that you can get statistic information on successful or failed incoming and outgoing calls.

To start the Diva Server Monitor, click ‘Start > Programs > Diva Server for Windows 2000/XP > Diva Server Monitor’.

The ‘Active Connections’ view of the Diva Server Monitor provides information on currently active connections (see Active connections on page 103). The ‘System Overview’ provides information on the Diva Server adapters installed in your system and statistic information on all successful and failed connections of your computer (see System overview on page 104).

The monitor also appears as an icon in the system tray, as shown:

Traffic on the B-channels is indicated by bright blue bars in the monitor icon. You can display the status of the B-channels by placing your cursor over the icon. A tooltip shows how many of your total channels are active.

To stop the Diva Server Monitor, select ‘File > Exit’ if the ‘Active Connections’ or the ‘System Overview’ are open; or right-click the monitor icon and select ‘Exit’.
Active connections

The ‘Active Connections’ view provides the following details for all active connections:

- **Adapter:** Indicates the serial number of the adapter to which the B-channel belongs.
- **Service:** Indicates which B-channel protocol is used for the call, e.g. Digital Data, Digital Data T.70, Modem Data, Modem HDLC, Fax, Voice, V.110, etc.
- **Direction:** Indicates if an incoming or outgoing call is established on the B-channel.
- **Remote Number:** Indicates the ISDN number of the remote station.
- **Local Number:** Indicates the ISDN number of the local station.
- **Connected Since:** Indicates the time when the connection was started.
- **Charges:** Indicates the charges of a connection. This information can only be displayed if charge information is supplied by the switch.
- **Channel:** Indicates the channel number.
- **Line Type:** Indicates which line type the channel uses, dialup or leased line.
System overview

The ‘System Overview’ shows detailed information on the installed adapters and gives a statistic overview on successful and failed incoming and outgoing connections on a per adapter basis.

- **Adapter Type**: Indicates the adapter that is installed in your system, e.g. Diva Server BRI-2M PCI.

  The LED icons left from the adapter name indicate the operating status of your adapter as follows:
  - **Red**: Layer 1 is down. The adapter is not operational.
  - **Yellow**: Layer 1 is up and the adapter is ready to connect. The D-channel layer 2 connection is not yet established. The D-channel layer 2 connect mode depends on your ISDN line. You can select the required connect mode settings in the configuration manager (see [Layer 2 Connect Mode](#) on page 46).
  - **Green**: Layer 1 and the D-channel layer 2 connection are up. The adapter is ready to connect or running.

- **Serial Number**: Indicates the serial number of your adapter. This number is automatically read from the adapter.

- **Status**: Indicates the current status of the Diva Server adapter, e.g. running, connecting, layer 1 error, etc.

- **Active Connections**: Indicates the number of calls that are currently active on the Diva Server adapter.

- **Successful Incoming**: Indicates the number of successfully established incoming calls.

- **Failed Incoming**: Indicates the number of incoming call attempts where no connection could be established.
• Successful Outgoing: Indicates the number of successfully established outgoing connections.

• Failed Outgoing: Indicates the number of outgoing call attempts that failed.

Properties

The system overview also offers detailed information on adapter properties for all installed adapters. To view adapter details, right-click the adapter and select ‘Properties’.

The displayed dialog box shows the adapter’s name, its serial number, the number of B-channels it supports, and the number of available modems which corresponds to the number of simultaneous analog connections that can be established via the adapter. It also shows whether the installed adapter provides fax, modem, and VoIP support.
CHAPTER 13

Maintenance Tools

Diva Server for Windows 2000/XP offers the following tools for testing your connection and diagnosing and solving problems that might occur with your Diva Server adapter or the ISDN connection:

- Check ISDN line
- Diva Server Diagnostics

The Line Check tool allows you to quickly verify that your Diva Server adapter and ISDN line are working properly (see below).

The Diva Server Diagnostics tool can help with the analysis of problems if difficulties are encountered with the Eicon ISDN drivers or the ISDN connection.

Every Eicon ISDN driver sends status messages, and reports any error situations that occur. The messages are saved in a specific memory area of a fixed size, so that the oldest messages are overwritten when the memory is full.

Diva Server Diagnostics enable the messages from Diva Server adapters and various drivers and to be displayed and saved (see Diva Server Diagnostics on page 108).

Line Check

To use the Line Check utility, you must have installed your Eicon Diva Server adapter, installed Diva Server for Windows 2000/XP and connected your ISDN line to the adapter.

1. Run Line Check by selecting ‘Start > Programs > Diva Server for Windows 2000/XP > Check ISDN Line’.

If you have several adapters or one of the Diva Server 4BRI adapters installed, select
the adapter or controller you want to test. Then, click ‘Start’ to begin the check.

3. If the Line Check utility reports an error, verify that:
   - Your cabling is connected correctly.
   - Your ISDN switch type, network type, ISDN numbers, and SPIDs are correct.
   - Your Diva Server adapter is not conflicting with any other hardware.
   - Your telco company is not experiencing any problems.

   If the Line Check utility reports no problems, and you are still having trouble
   connecting, there might be a problem in the configuration of the application you are
   using with your Diva Server adapter (such as Dial-Up Networking or fax software).

4. Click ‘Finish’.
Diva Server Diagnostics

The Diva Server Diagnostics tool allows you to display information on driver messages, CAPI messages, and the operating status of the ISDN D-channel and B-channels that is saved in the adapter memory. The tool has a graphical user interface where you can set various trace levels or individual trace options for each driver and adapter. This allows you to have everything up to PPP frames listed or to suppress unnecessary (in that situation) trace information.

1. To start the Diva Server Diagnostics tool, click ‘Start > Programs > Diva Server for Windows 2000/XP > Diva Server Diagnostics’. The Diva Server Diagnostics welcome screen is displayed.
2. Configure the output options for your trace files. To do so, click ‘Tracing > Configuration’ or click the configuration button in the toolbar. The following dialog box appears:

3. Click the ‘Output’ tab.

4. In ‘Directory’, enter the path where the trace files are to be saved.

5. To use the default file names, enable the ‘Use default file names’ option. Otherwise, enter the desired file name in ‘File name’.

6. To generate a cyclic trace file, enable the ‘Cycle Output Files’ option. Specify the number of files to be generated in ‘Maximum Files’. A cyclic trace writes trace messages into several files, overwriting the oldest information when the last file is full. Thus, you have a large buffer for trace messages that allows you to monitor events and errors over long periods of time.

7. Enter the maximum size for your trace files in kbytes.

8. Specify whether existing traces should be overwritten when you restart the Diva Diagnostics tool. If you disable this option, the trace file is continued endlessly.

9. Click the ‘Editor’ tab to specify the editor that should be used to view the trace output.

10. Click ‘OK’ to save the output settings.

11. Set the trace masks according to the support personnel’s advice. See also Individual trace options below and Predefined trace masks on page 110.

12. Start the tracing. Click ‘Tracing > Start Tracing’ or click the start trace button in the toolbar.

13. To stop tracing, click ‘Tracing > Stop Tracing’ or click the stop trace button in the toolbar.
Individual trace options

You can set individual trace options for each installed adapter or software driver. To do so, click the corresponding folder in the left pane and enable the required trace option in the right pane.

![Diva Server Diagnostics tool](image)

To enable the highest trace level for the selected driver or adapter in one step, click ‘Edit > Select All’ or click the corresponding button in the toolbar.

To return to the minimum trace level, click ‘Edit > Clear All’ or click the corresponding button in the toolbar.

**Note:** The highest trace level requires a high computing capacity. Set this level only if you are experiencing problems with an adapter or a driver and could not locate the error using one of the predefined trace masks.

Predefined trace masks

The Diva Server Diagnostics tool provides predefined trace masks that allow you to record various levels of information on your adapter or your software drivers.

The minimum trace mask gives an overview of the most important events. See Minimum trace mask on page 111.

The basic level trace mask helps you to find the cause of a problem in a first step if any problems occur during operation of the Diva Server adapter. If the basic level mask does provide enough information to locate the error, set the extended level trace mask to record further information. See Basic and extended trace masks for adapters, drivers, and services on page 111.
Minimum trace mask

Set the minimum trace mask to get an overview of errors and the most important events on the installed software drivers. To do so, click ‘Tracing > Minimum Trace Mask’ or click the corresponding button in the toolbar.

The minimum trace mask influences the settings for all installed adapters, drivers, and services and changes all trace masks to a minimum level. The following messages are displayed:

- General Logging: Records information on the startup or termination of the respective driver.
- Fatal errors: Records fatal errors that prevent the respective driver from being started or from working.
- Errors: Records general errors that are reported during startup or runtime and that might be problematic or not.

Basic and extended trace masks for adapters, drivers, and services

If any problems occur during operation of the Diva Server adapter, set the basic level trace mask to find the cause of a problem in a first step. If the basic level mask does not help to locate the error, set the extended level trace mask to record further information.

You have to set the basic or extended trace masks for each adapter, service, or driver separately. To select a trace mask, click ‘Tracing > Predefined Trace Mask’ and select the required mask.

Trace masks for Diva Server adapters

The trace masks for Diva Server adapters display information on the operating status of the D-channel and B-channels that is saved in the adapter memory.

The following information can be recorded:

- Layer 1: Records all layer 1 state changes, i.e. activated or down.
- D-Channel: Records D-channel data as raw hex frames.
- Call Comments (SIG): Records decoded information on signaling frames.
- Data Link Errors: Records all layer 2 data link errors.
- Low Layer: Records decoded low layer information.
- Network Layer: Records B-channel establishment and data indication messages.
- Modulation: Records information on modulation and demodulation.
- Miscellaneous: Records clear text information on call states etc.
- Extended: Records detailed module-specific information.
Trace masks for the maintenance driver

If you are experiencing problems with the maintenance driver, ISDN Direct Interface Device (DIDD) driver, or the IOCTL (interface for applications with additional ISDN functions that are not available over the known standard interfaces), enable the basic trace mask as a first step. If you cannot find the cause of the problem using the basic level trace mask, enable the extended trace mask to record further information.

Trace masks for CAPI

If you are experiencing problems with your CAPI or your TAPI service, enable the basic trace mask as a first step. If you cannot find the cause of the problem using the basic level trace mask, enable the extended trace mask to record further information on the CAPI driver.

Trace masks for RAS

If you are experiencing problems with RAS (WAN Miniport), enable the basic trace mask as a first step. If you cannot find the cause of the problem using the basic level trace mask, enable the extended trace mask to record further information on RAS.

Trace masks for the Eicon Port driver

If you are experiencing problems with your Port driver, enable the basic trace mask as a first step. If you cannot find the cause of the problem using the basic level trace mask, enable the extended trace mask to record further information.

Development-level trace options

All trace options that are not covered by the pre-defined trace masks generate traces at development level. They are rarely used by Eicon development to locate very specific problems.
CHAPTER 14

Features

Each of Eicon’s Diva Server adapters provides different features and capabilities with Diva Server for Windows 2000/XP. The table below outlines the feature set of Eicon Diva Server adapters.

However, all features may not be available on all the supported interfaces. The interfaces supported by Eicon Diva Server adapters are as follows:

<table>
<thead>
<tr>
<th>Interface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDI</td>
<td>ISDN Direct Interface. Supports all features and capabilities of Eicon ISDN adapters.</td>
</tr>
<tr>
<td>WAN Miniport</td>
<td>Provides support for WAN protocols running over ISDN or channelized T1. Useful for connecting to Windows 2000/XP Remote Access Services (RAS).</td>
</tr>
<tr>
<td>COM Port</td>
<td>For applications that require communications via a standard PC communications port.</td>
</tr>
<tr>
<td>CAPI 2.0</td>
<td>Common ISDN Application Programming Interface. A standard interface for applications to interact with ISDN adapters.</td>
</tr>
<tr>
<td>TAPI</td>
<td>Telephony Application Programming Interface. An interface for communication programs to work with telephony and network services.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Features via interface:</th>
<th>IDI</th>
<th>WAN MiniPort</th>
<th>COM Port</th>
<th>CAPI 2.0</th>
<th>TAPI</th>
</tr>
</thead>
<tbody>
<tr>
<td>B-channel related:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Transparent HDLC, 64/56(^{8}) kbps</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>Transparent (Voice)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>X.75 64/56(^{8}) kbps</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>T.70/T.90 (T-Online)</td>
<td>•</td>
<td></td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>V.110 (GSM)(^{1})</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>V.120 64/56 kbps (CompuServe)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>V.34+, V.90 analog modem(^{18})</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>V.42, V.42bis(^{18})</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>X.75/V.42bis</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change of B-channel protocol during a call</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td>•</td>
</tr>
<tr>
<td>X.25(^{2}), X.31, ISO 8208 in the B-channel</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•(6)</td>
</tr>
<tr>
<td>PIAFS 1.0 and 2.1(^{8})</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Features via interface:</td>
<td>IDI</td>
<td>WAN MiniPort</td>
<td>COM Port</td>
<td>CAPI 2.0</td>
<td>TAPI</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----</td>
<td>--------------</td>
<td>----------</td>
<td>----------</td>
<td>------</td>
</tr>
<tr>
<td>SDLC</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax Group 4 (incl. T.90/ISO8208 and module mode detection)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
</tr>
<tr>
<td>T.30 Fax Group 3 (analog), Class 1 and 2</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax with Error Correction Mode (ECM)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Fax with MR (D2 coding)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Fax with MMR (T.6 coding)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Fax 14.4 kbps</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Fax 33.6 kbps (V.34)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax tone detection</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Reversal of fax direction</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Fax polling / fax on demand</td>
<td>•</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Speed and feature indication (polling and ECM)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>New fax header line</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page formats: ISO A4, ISO B4, ISO A3</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Resolution: standard, fine, super-fine, ultra-fine</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DTMF tone detection and transmission</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>On-board switching and conferencing (via line interconnect)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Media mode (unknown, interactive voice, automated voice)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Wave audio format (8 bit 8 kHz A-Law, 8 bit 8 kHz µ-Law, 8 bit 8 kHz PCM, 16 bit 8 kHz PCM)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Echo cancellation</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Real time protocol (RTP)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Comfort noise generation (CNG)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Voice activity detection (VAD)</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Dynamic anti-jitter buffer</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Audio tap</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GSM and G.726 voice codecs</td>
<td>•</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Supplementary Services:**

MSN (multiple subscriber number)
<table>
<thead>
<tr>
<th>Features via interface:</th>
<th>IDI</th>
<th>WAN MiniPort</th>
<th>COM Port</th>
<th>CAPI 2.0</th>
<th>TAPI</th>
</tr>
</thead>
<tbody>
<tr>
<td>DDI (direct dialing-in)</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>SUB (sub-addressing)</td>
<td>●</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
</tr>
<tr>
<td>CLIP (calling line identification presentation)</td>
<td>●</td>
<td>●</td>
<td></td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>CLIR (calling line identification restriction)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>COLP (connected line identification presentation)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>COLR (connected line identification restriction)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td>●</td>
</tr>
<tr>
<td>KEY (keypad protocol)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>TP (terminal portability)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Call forwarding unconditional</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Call forwarding busy</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Call forwarding no reply</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Call deflection</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>CW (call waiting)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>HOLD (hold and retrieve a call)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>ECT (explicit call transfer)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Blind transfer</td>
<td></td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>AoC (advice of charge)</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Three-party conference</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Large conference</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>User-to-user signaling</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>Transparent D-channel</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
<tr>
<td>X.25/D-channel including AO/DI support</td>
<td>●</td>
<td></td>
<td></td>
<td>●</td>
<td></td>
</tr>
</tbody>
</table>

1) Features are not available with Diva Server PRI adapters without modules, the Diva Server PRI-0M, or the Diva Server T1/PRI adapter without additional DSPs.

2) CAPI 2.0 supports X.25 in the B- and D-channel, permanent virtual connections (PVC) and switched virtual connections (SVC), and multiple logical connections per B-channel. The COM port supports X.25 with one PVC in the B-channel.

3) DTMF tone detection and transmission is done via soft DTMF for Diva Server adapters without additional DSPs.

4) For an overview on supplementary services support by the various switch types, see [Supplementary services](#).
5) The COM Port supports fax polling for Fax Class 1 only.
6) Features are available with TAPI via Unimodem support.
7) Features are not available with Diva Server BRI-2M (rev.1) adapters.
8) Features are not available with Diva Server 2FX adapters.
9) For an overview on switching and conferencing support by the various Diva Server adapters, see On-board switching and conferencing below.

**On-board switching and conferencing**

Some switches do not offer supplementary services such as call transfer, overlap sending, three-party conference, or large conference. For these switches, the Diva Server adapters and software can provide these supplementary services by connecting or forwarding calls directly on the adapter.

Support for on-board switching and conferencing depends on the installed Diva Server adapter. The table below outlines the various types of switching and their support by Diva Server adapters.

**Note:** On-board switching and conferencing is only possible if it is supported by your application.

<table>
<thead>
<tr>
<th>Switching and conferencing via adapter:</th>
<th>Switching and conferencing (within one board)</th>
<th>Cross-board switching and conferencing (fully featured)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Diva Server 2FX</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diva Server BRI-2M (rev. 1)</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Diva Server BRI-2M 2.0, Diva Server Voice BRI-2M 2.0</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Diva Server 4BRI-8M (rev. 1), Diva Server Voice 4BRI-8M (rev. 1)</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Diva Server 4BRI-8M 2.0, Diva Server Voice 4BRI-8M 2.0</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Diva Server PRI (rev. 1) without additional DSPs</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Diva Server PRI (rev. 1) with additional DSPs</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Diva Server PRI 2.0 without additional DSPs</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Diva Server PRI 2.0 with additional DSPs</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Diva Server Voice PRI</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>
Supplementary services

The Diva Server for Windows 2000/XP software supports basic call services for all switch types that are available in the Diva Server Configuration Manager. In addition to this, it offers supplementary services for the following switch types:

- Euro-ISDN (ETSI) BRI and PRI
- 5ESS Custom (AT&T)
- 5ESS NI (Lucent/Avaya)
- DMS 100 (Nortel)
- Q-Sig

Q-Sig support is available for the derivatives ETSI-SS, ECMA-QSIG, and ETSI-QSIG. Thus, the Q-Sig switch type can be used with any PBX based on one of these derivatives.

Q-Sig has been tested with a number of various switches, for example, Hicom 150, Hicom 300, Lucent Definity, Alcatel 4200, Alcatel 4400, Ericsson MD 110, Ericsson P250, Nortel Meridian, Nortel M65xx, Siemens HiPath 3000, and Siemens HiPath 4000.

The table below gives a detailed overview of the supplementary services supported by the switch types listed above.

**Note:** The availability of supplementary services also depends on your PBX. For detailed information on supplementary services supported by your PBX, contact the PBX manufacturer.

<table>
<thead>
<tr>
<th>Supplementary services with switch type</th>
<th>Euro-ISDN (ETSI) PRI</th>
<th>Euro-ISDN (ETSI) BRI</th>
<th>Q-Sig</th>
<th>5ESS Custom (AT&amp;T), 5ESS NI (Lucent/Avaya), DMS 100</th>
</tr>
</thead>
<tbody>
<tr>
<td>MSN (multiple subscriber number)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>• (incoming)</td>
</tr>
<tr>
<td>DDI (direct dialing-in)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>SUB (sub-addressing)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Supplementary services with switch type</td>
<td>Euro-ISDN (ETSI) PRI</td>
<td>Euro-ISDN (ETSI) BRI</td>
<td>Q-Sig</td>
<td>5ESS Custom (AT&amp;T), 5ESS NI (Lucent/Avaya), DMS 100</td>
</tr>
<tr>
<td>---------------------------------------------------------</td>
<td>----------------------</td>
<td>----------------------</td>
<td>---------------------------</td>
<td>------------------------------------------------------</td>
</tr>
<tr>
<td>CLIP (calling line identification presentation)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>CLIR (calling line identification restriction)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>COLP (connected line identification presentation)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>COLR (connected line identification restriction)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>KEY (keypad protocol)</td>
<td>•</td>
<td>•</td>
<td>•5)</td>
<td></td>
</tr>
<tr>
<td>AoC (advice of charge)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>User-to-user signaling</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>TP (terminal portability)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Call forwarding unconditional</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Call forwarding busy</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Call forwarding no reply</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Call deflection</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>CW (call waiting)</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>HOLD (hold and retrieve a call)</td>
<td>•1)</td>
<td>•</td>
<td>•2)</td>
<td>•4)</td>
</tr>
<tr>
<td>ECT (explicit call transfer)</td>
<td>•</td>
<td>•3)</td>
<td>•4)</td>
<td></td>
</tr>
<tr>
<td>Path replacement</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Single-step call transfer (over CAPI deflection)</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Three-party conference</td>
<td>•</td>
<td>•</td>
<td>•4)</td>
<td></td>
</tr>
<tr>
<td>Large conference</td>
<td>•4)</td>
<td>•</td>
<td>•4)</td>
<td></td>
</tr>
<tr>
<td>Drop conference</td>
<td>•</td>
<td>•</td>
<td>•4)</td>
<td></td>
</tr>
<tr>
<td>Name identification services</td>
<td></td>
<td>(presented by switch)</td>
<td>(presented by network)</td>
<td></td>
</tr>
<tr>
<td>Generic functional procedures (basis for supplementary services in Q-Sig environment)</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
</tbody>
</table>
### Supplementary services with switch type

<table>
<thead>
<tr>
<th>Feature</th>
<th>Euro-ISDN (ETSI) PRI</th>
<th>Euro-ISDN (ETSI) BRI</th>
<th>Q-Sig</th>
<th>5ESS Custom (AT&amp;T), 5ESS NI (Lucent/Avaya), DMS 100</th>
</tr>
</thead>
<tbody>
<tr>
<td>Common information</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Redirected number translation from Q-Sig to Q.931</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Escape message types</td>
<td></td>
<td></td>
<td>(5ESS Custom only)</td>
<td></td>
</tr>
<tr>
<td>Call Appearance/Call Handling (CACH) plus configuration</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Feature activators plus configuration</td>
<td></td>
<td></td>
<td>•</td>
<td>(5ESS NI + DMS 100 only)</td>
</tr>
<tr>
<td>Network display conversion/treatment</td>
<td></td>
<td></td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Message waiting</td>
<td>•</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>

1) HOLD is not a standard supplementary service for Euro-ISDN PRI, nevertheless some PBXs support call hold and retrieve.

2) HOLD is not defined in Q-Sig but corresponding procedures are available.

3) Call transfer is only possible if path replacement works.

4) Services are not available with Diva Server BRI-2M (rev. 1) adapters.

5) In a Q-Sig environment, the feature is also called ‘Simple Dialog’.